• HDU-2126 Buy the souvenirs


    数组01背包。

    http://acm.hdu.edu.cn/showproblem.php?pid=2126

    http://blog.csdn.net/crazy_ac/article/details/7869411

    f[i][j][k]表示前i种物品,买了j个,花了小于等于k的钱的时候的方案数

    因为是小于等于k,所以初始化的时候要注意哦。

    那么转移的时候第i种物品取或者不取

     f[i][j][k]+=f[i-1][j][k];
       f[i][j][k]+=f[i-1][j-1][k-v[i]];

                          Buy the souvenirs

    Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 748    Accepted Submission(s): 255

    Problem Description
    When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:
    And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).
     
    Input
    For the first line, there is a T means the number cases, then T cases follow. In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir.
    All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.
     
    Output
    If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”
     
    Sample Input
    2
    4 7
    1 2 3 4
    4 0
    1 2 3 4
     
    Sample Output
    You have 2 selection(s) to buy with 3 kind(s) of souvenirs.
    Sorry, you can't buy anything.
    #include<iostream>
    #include<cstring>
    using namespace std;
    int f[50][50][510],v[50];
    int n,m,ans1,ans2;
    int fun()
    {
        int i,j,k;
        for(i=n;i>0;i--)
          for(j=i;j>0;j--)
             for(k=m;k>=0;k--)
               if(f[i][j][k])
                    {
                        ans1=f[i][j][k];
                        ans2=j;
                        return 1;
    
                    }
    
    
             return 0;
    }
    int main()
    {
        int i,j,k,t;
        cin>>t;
        while(t--)
        {
    
            memset(v,0,sizeof(v));
            cin>>n>>m;
            for(i=1;i<=n;i++)
               cin>>v[i];
              memset(f, 0, sizeof(f));
                 for(i = 0; i <= n; i++)
                   for(j = 0; j <= m; j++)
                      f[i][0][j] = 1;
             for(i=1;i<=n;i++)
              for(j=1;j<=i;j++)
                for(k=m;k>=0;k--)
                  {
                     f[i][j][k]+=f[i-1][j][k];
                     if(k>=v[i])
                       f[i][j][k]+=f[i-1][j-1][k-v[i]];
                  }
                  if(fun())
                     cout<<"You have "<<ans1<<" selection(s) to buy with "<<ans2<<" kind(s) of souvenirs."<<endl;
                  else
                     cout<<"Sorry, you can't buy anything."<<endl;
            }
            return 0;
        }
    
     
  • 相关阅读:
    2017.08.07 python爬虫实战之使用代理爬取糗事百科
    2017.08.05 Python网络爬虫实战之获取代理
    2017.08.04 Python网络爬虫之Scrapy爬虫实战二 天气预报的数据存储问题
    2017.08.04 Python网络爬虫之Scrapy爬虫实战二 天气预报
    2017.07.28 Python网络爬虫之爬虫实战 重新梳理------今日影视爬虫(使用Scrapy爬取ajax动态页面)
    2017.07.28 Python网络爬虫之爬虫实战 今日影视2 获取JS加载的数据
    RabbitMQ之工作队列
    pt-online-schema-change和默认值关系
    flex词法解析
    Makefile持续学习二
  • 原文地址:https://www.cnblogs.com/cancangood/p/3583415.html
Copyright © 2020-2023  润新知