• POJ 1459 Power Network(网络流 最大流 多起点,多汇点)


    Power Network
    Time Limit: 2000MS   Memory Limit: 32768K
    Total Submissions: 22987   Accepted: 12039

    Description

    A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

    An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

    Input

    There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

    Output

    For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

    Sample Input

    2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
    7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
             (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
             (0)5 (1)2 (3)2 (4)1 (5)4

    Sample Output

    15
    6

    Hint

    The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

    Source

    设一个虚的起点0-和一个虚的汇点n+1
    #include<cstring>
    #include<queue>
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<limits>
    using namespace std;
    int n,m,sn,en;
    int mx[105][105],a[105],flow[105][105],f[105];
    void pre()
    {
        int u,v,value;
        memset(mx,0,sizeof(mx));
        for(int i=0;i<m;i++){
            scanf(" (%d,%d)%d",&u,&v,&value);
            mx[u+1][v+1]+=value;
        }
        for(int i=0;i<sn;i++){
            scanf(" (%d)%d",&u,&value);
            mx[0][u+1]+=value;
        }
        for(int i=0;i<en;i++){
            scanf(" (%d)%d",&u,&value);
            mx[u+1][n+1]+=value;
        }
    }
    int solve()
    {
        int ans=0;
        queue<int> q;
        memset(flow,0,sizeof(flow));
        while(1){
            memset(a,0,sizeof(a));
            a[0]=INT_MAX;
            q.push(0);
            while(!q.empty()){
                int u=q.front();q.pop();
                for(int v=0;v<=n+1;v++){
                    if(!a[v]&&mx[u][v]>flow[u][v]){
                        a[v]=min(a[u],mx[u][v]-flow[u][v]);
                        q.push(v);
                        f[v]=u;
                    }
                }
            }
            if(!a[n+1]) 
                return ans;
            for(int v=n+1;v!=0;v=f[v]){
                flow[f[v]][v]+=a[n+1];
                flow[v][f[v]]-=a[n+1];
            }
            ans+=a[n+1];
        }
    }
    int main(void)
    {
        while(cin>>n>>sn>>en>>m){
            pre();
            cout<<solve()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    2017 ACM/ICPC Asia Regional Qingdao Online
    2017 ACM/ICPC Asia Regional Qingdao Online
    2017 ACM-ICPC 亚洲区(西安赛区)网络赛 Sum
    2017 ACM/ICPC Asia Regional Shenyang Online array array array
    无权最短路
    解题报告:poj 3070
    矩阵学习笔记
    拓扑排序
    LIS严格递增和非递减模板
    2017 ACM-ICPC 亚洲区(乌鲁木齐赛区)网络赛-A banana·
  • 原文地址:https://www.cnblogs.com/woshijishu3/p/3905571.html
Copyright © 2020-2023  润新知