• 2017 beijing icpc A


    2017-09-22 21:59:43

    writer:pprp

    HazelFan is given two positive integers a,ba,b, and he wants to calculate amodbamodb. But now he forgets the value of bb and only remember the value of aa, please tell him the number of different possible results.

    InputThe first line contains a positive integer T(1T5)T(1≤T≤5), denoting the number of test cases. 
    For each test case: 
    A single line contains a positive integer a(1a109)a(1≤a≤109).
    OutputFor each test case: 

    A single line contains a nonnegative integer, denoting the answer. 

    Sample Input

    2
    1
    3

    Sample Output

    2
    3
    #include<iostream>
    #include<string.h>
    #include<stdlib.h>
    
    using namespace std;
    
    int main()
    {
        int i,n;
        cin>>n;
        for(i = 0;i<n;++i)
        {
            int x;
            cin>>x;
            if(x%2==0)
            {
                cout<<(x/2)+1<<endl;
            }
            else if(x%2 == 1)
            {
                x++;
                cout<<(x/2)+1<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    密文搜索
    poj 1182 食物链
    1147. Heaps (30)
    1146. Topological Order (25)
    1145. Hashing
    1142. Maximal Clique (25)
    fzu 2112 tickets
    51nod 1554 欧姆诺姆和项链
    codeforces 963B Destruction of a Tree
    hdu 3294 Girls' research
  • 原文地址:https://www.cnblogs.com/pprp/p/7577366.html
Copyright © 2020-2023  润新知