• L2-011 玩转二叉树 (25 分) (树)


    链接:https://pintia.cn/problem-sets/994805046380707840/problems/994805065406070784


    题目:

    给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

    输入格式:

    输入第一行给出一个正整数N≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

    输出格式:

    在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

    输入样例:

    7
    1 2 3 4 5 6 7
    4 1 3 2 6 5 7
    

    输出样例:

    4 6 1 7 5 3 2


    思路:
    在用中序遍历和前序遍历建树的时候 把左儿子和右儿子的递归交换一下即可建成镜像二叉树

    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cmath>
    #include <string>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    #include <queue>
    
    using namespace std;
    typedef long long ll;
    typedef unsigned long long ull;
    const int inf=0x3f3f3f3f;
    const int maxn=50;
    int n;
    int pr[maxn],mid[maxn];
    
    struct node{
        int l,r;
    }T[maxn];
    
    int mid_pr_find(int la,int ra,int lb,int rb){
        if(la>ra) return 0;
        int rt=pr[lb];
        int p1=la,len;
        while(mid[p1]!=rt) p1++;
        len=p1-la;
        T[rt].r=mid_pr_find(la,p1-1,lb+1,lb+len);
        T[rt].l=mid_pr_find(p1+1,ra,lb+len+1,rb);
        return rt;
    }
    
    void bfs(int rt){
        queue<int>Q;
        vector<int>v;
        Q.push(rt);
        while(!Q.empty()){
            int w=Q.front();
            Q.pop();
            v.push_back(w);
            if(T[w].l!=0) Q.push(T[w].l);
            if(T[w].r!=0) Q.push(T[w].r);
        }
        int len=v.size();
        for(int i=0;i<len;i++){
            printf("%d%c",v[i],i==(len-1)?'
    ':' ');
        }
    }
    
    int main(){
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%d",&mid[i]);
        for(int i=0;i<n;i++) scanf("%d",&pr[i]);
        int rt=mid_pr_find(0,n-1,0,n-1);
        bfs(rt);
        return 0;
    }
  • 相关阅读:
    5285: [Hnoi2018]寻宝游戏
    CF 1117 E. Decypher the String
    4515: [Sdoi2016]游戏
    CF 1051 G. Distinctification
    4820: [Sdoi2017]硬币游戏
    HNOI2019游记
    最近公共祖先(LCT)
    [WC2006]水管局长(LCT)
    P4178 Tree(点分治)
    二维凸包
  • 原文地址:https://www.cnblogs.com/whdsunny/p/10624868.html
Copyright © 2020-2023  润新知