• Parlindrome subsequence_dp


    Problem Description
    In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
    (http://en.wikipedia.org/wiki/Subsequence)

    Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, ..., Sxk> and Y = <Sy1, Sy2, ..., Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.
     
    Input
    The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
     
    Output
    For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
     
    Sample Input
    4 a aaaaa goodafternooneveryone welcometoooxxourproblems
     
    Sample Output
    Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960

     【题意】给出一个字符串,求其中含有多少个回文串。

    【思路】dp[i][j]表示i到j区间内的回文串数。

    #include<iostream>
    #include<algorithm>
    #include<string.h>
    using namespace std;
    
    const int mod=10007;
    const int N=1010;
    char str[N];
    int dp[N][N];
    
    int main()
    {
        int t,cas=1;
        scanf("%d",&t);
        
        while(t--)
        {
            scanf("%s",str);
            int len=strlen(str);
            
            memset(dp,0,sizeof(dp));
            
            for(int i=0;i<len;i++)
            {
                dp[i][i]=1;
            }
            for(int i=0;i<len;i++)
                for(int j=i-1;j>=0;j--)
                {
                    dp[j][i]=(dp[j+1][i]+dp[j][i-1]-dp[j+1][i-1]+mod)%mod;//加上mod是以免被取模的数为负
    //中间j+1到i-1的部分重复了
    if(str[i]==str[j]) dp[j][i]=(dp[j][i]+dp[j+1][i-1]+1+mod)%mod;//两端相等的话,要加上dp[j+1][i-1]+1;
    //两端可以组成一个回文串,两端可以与其间任意一个回文串组成新的回文串,数量将增加dp[j+1][i-1]+1; } printf(
    "Case %d: %d ",cas++,dp[0][len-1]); } return 0; }
  • 相关阅读:
    9.17考试
    Something
    tesuto-Mobius
    7.22考试
    填坑...P1546 最短网络 Agri-Net
    P1125 笨小猴
    P2822 组合数问题
    致我们曾经刷过的水题
    Luogu P1186 玛丽卡
    Luogu P1726 上白泽慧音
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/6364720.html
Copyright © 2020-2023  润新知