• 1025 PAT Ranking (25 分)


    Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (≤), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

    registration_number final_rank location_number local_rank
     

    The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

    Sample Input:

    2
    5
    1234567890001 95
    1234567890005 100
    1234567890003 95
    1234567890002 77
    1234567890004 85
    4
    1234567890013 65
    1234567890011 25
    1234567890014 100
    1234567890012 85
     

    Sample Output:

    9
    1234567890005 1 1 1
    1234567890014 1 2 1
    1234567890001 3 1 2
    1234567890003 3 1 2
    1234567890004 5 1 4
    1234567890012 5 2 2
    1234567890002 7 1 5
    1234567890013 8 2 3
    1234567890011 9 2 4
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=100010;
    #define esp 1e-8
    struct node{
        string id;
        int grade;
        int rankf;
        int rankl;
        int locat;
    }st[maxn];
    bool cmp(node a,node b){
        if(a.grade!=b.grade){
            return a.grade>b.grade;
        }
        else{
            return a.id<b.id;
        }
    }
    int main(){
        int n,m,k,t=0,r=0;
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>m;
            r+=m;
            for(int j=t;j<r;j++){
                cin>>st[j].id>>st[j].grade;
                st[j].locat=i+1;
            }
            sort(st+t,st+r,cmp);
            st[t].rankl=1;
            for(int k=1+t;k<r;k++){
                if(st[k].grade==st[k-1].grade){
                    st[k].rankl=st[k-1].rankl;
                }
                else{
                    st[k].rankl=k+1-t;
                }
            }
            t+=m;
            
        }
        cout<<r<<endl;
        sort(st,st+r,cmp);
        st[0].rankf=1;
        for(int i=1;i<r;i++){
            if(st[i].grade==st[i-1].grade){
                st[i].rankf=st[i-1].rankf;
            }
            else{
                st[i].rankf=i+1;
            }
        }
        for(int i=0;i<r;i++){
            cout<<st[i].id<<" "<<st[i].rankf<<" "<<st[i].locat<<" "<<st[i].rankl<<endl;
        }
        return 0;
    }

     优化:

    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=100010;
    #define esp 1e-8
    struct node{
        string id;
        int grade;
        int rankf;
        int rankl;
        int locat;
    };
    bool cmp(node a,node b){
        if(a.grade!=b.grade){
            return a.grade>b.grade;
        }
        else{
            return a.id<b.id;
        }
    }
    vector<node> v;
    int main(){
        int n,m,k,t=0;
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>m;
            vector<node> ve(m);
            for(int j=0;j<m;j++){
                cin>>ve[j].id>>ve[j].grade;
                ve[j].locat=i+1;
            }
            sort(ve.begin(),ve.end(),cmp);
            ve[0].rankl=1;
            v.push_back(ve[0]);
            for(int k=1;k<m;k++){
                if(ve[k].grade==ve[k-1].grade){
                    ve[k].rankl=ve[k-1].rankl;
                }
                else{
                    ve[k].rankl=k+1;
                }
                v.push_back(ve[k]);
            }
        }
        int len=v.size();
        cout<<len<<endl;
        sort(v.begin(),v.end(),cmp);
        v[0].rankf=1;
        for(int i=1;i<len;i++){
            if(v[i].grade==v[i-1].grade){
                v[i].rankf=v[i-1].rankf;
            }
            else{
                v[i].rankf=i+1;
            }
        }
        for(int i=0;i<len;i++){
            cout<<v[i].id<<" "<<v[i].rankf<<" "<<v[i].locat<<" "<<v[i].rankl<<endl;
        }
        return 0;
    }
  • 相关阅读:
    NOIp2018集训test-9-4
    「THUSC 2016」成绩单 & 方块消除 (区间dp)
    NOIp2018集训test-9-2(pm)
    NOIp2018集训test-9-2(am)
    NOIp2018集训test-9-1(pm)
    NOIp2018集训test-9-1(am)
    暑假集训test-8-31(pm)
    暑假集训test-8-31(am)
    暑假集训test-8-30
    day22 笔记
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14460524.html
Copyright © 2020-2023  润新知