• 1027. Colors in Mars


    1027. Colors in Mars (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

    Input

    Each input file contains one test case which occupies a line containing the three decimal color values.

    Output

    For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

    Sample Input
    15 43 71
    
    Sample Output
    #123456
    import java.util.Scanner;
    
    public class Main {
    
    	public static void main(String[] args) {
    		Scanner in=new Scanner(System.in);
    		int n;
    		String s="";
    		for(int i=0;i<3;i++){
    			n=in.nextInt();
    			s=change(n)+s;
    			//System.out.println(s);
    		}
    		s=s+"#";
    		for(int i=s.length()-1;i>=0;i--){
    			System.out.print(s.charAt(i));
    		}
    		System.out.println();
    	}
    
    	private static String change(int n) {
    		if(n==0) return "00";
    		String s="";
    		int tmp;
    		while(n!=0){
    			tmp=n%13;
    			if(tmp<10){
    				s=s+tmp;
    			}
    			else{
    				if(tmp==10) s=s+"A";
    				if(tmp==11) s=s+"B";
    				if(tmp==12) s=s+"C";
    			}
    			n=n/13;
    			//System.out.println(tmp+" "+n+" "+s);
    		}
    		if(s.length()==1) s=s+"0";
    		return s;
    	}
    
    }
    

      注意点:当输入数字为0的时候,还有左补0

  • 相关阅读:
    解题:HNOI 2008 玩具装箱
    2016级算法第一次上机助教版解题报告
    求解斐波那契数列复杂度分析
    数据库复习之规范化理论应用(第八次上机内容)
    数据库复习之规范化理论
    题目1042:Coincidence(最长公共子序列)
    题目1020:最小长方形(简单)
    题目1016:火星A+B(字符串拆分)
    题目1014:排名(结构体排序)
    题目1021:统计字符(hash简单应用)
  • 原文地址:https://www.cnblogs.com/chen20135517/p/7732004.html
Copyright © 2020-2023  润新知