• PTA | 1020. 月饼 (25)


    月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

    注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

    输入格式:

    每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

    输出格式:

    对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

    输入样例:

    3 20
    18 15 10
    75 72 45
    

    输出样例:

    94.50
    

    分析

    只要计算出每种月饼的单价然后sort从大到小排序即可,然后根据需求量大小分情况考虑

    #include<bits/stdc++.h>
    using namespace std;
    struct mooncake {
    	float mount, price, unit;
    };
    bool cmp(mooncake a, mooncake b) { return a.unit > b.unit; }
    int main() {
    	int n, need;
    	float result = 0.0;
    	cin >> n >> need;
    	vector<mooncake>a(n);
    	for (int i = 0; i < n; i++) scanf("%f", &a[i].mount);
    	for (int i = 0; i < n; i++) scanf("%f", &a[i].price);
    	for (int i = 0; i < n; i++) a[i].unit = a[i].price / a[i].mount;
    	sort(a.begin(), a.end(), cmp);
    	for (int i = 0; i < n; ++i) {
    		if (a[i].mount <= need)
    			result = result + a[i].price;
    		else {
    			result = result + a[i].unit*need;
    			break;
    		}
    		need -= a[i].mount;
    	}
    	printf("%.2f", result);//输出格式别忘了
    	return 0;
    }
    
  • 相关阅读:
    luoguP5024 保卫王国 动态dp
    luoguP4571 [JSOI2009]瓶子和燃料 裴蜀定理
    luoguP3235 [HNOI2014]江南乐 数论分块 + 博弈论
    luoguP4101 [HEOI2014]人人尽说江南好 结论
    hdu 3032 NIm or not Nim? Multi SG
    luoguP4279 [SHOI2008]小约翰的游戏 Anti-SG 博弈论
    luoguP3480 [POI2009]KAM-Pebbles 阶梯Nim
    Educational Codeforces Round 65 (Div. 2)
    [PKUSC2018]主斗地(搜索+贪心)
    Codeforces Round #557 (Div. 1)
  • 原文地址:https://www.cnblogs.com/RioTian/p/12436896.html
Copyright © 2020-2023  润新知