• POJ 1463 Strategic game【树形DP】


    Description

    Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

    Your program should find the minimum number of soldiers that Bob has to put for a given tree.

    For example for the tree:

    the solution is one soldier ( at the node 1).

    Input

    The input contains several data sets in text format. Each data set represents a tree with the following description:

    • the number of nodes
    • the description of each node in the following format
      node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
      or
      node_identifier:(0)

    The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

    Output

    The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

    Sample Input

    4
    0:(1) 1
    1:(2) 2 3
    2:(0)
    3:(0)
    5
    3:(3) 1 4 2
    1:(1) 0
    2:(0)
    0:(0)
    4:(0)

    Sample Output

    1
    2

    思路

    和间接上司那道题很像,每个支点有两种状态,放个士兵或者不放士兵。

    因此得到状态转移方程:

    dp[i][0]+=dp[i.son][1];

    dp[rr][1]+=min(dp[i.son][0], dp[i.son][1]);

    源码

    #include<stdio.h>

    #include<string.h>

    #include<vector>

    #include<iostream>

    using namespace std;

    int dp[1505][2];

    vector<int>V[1505];

    void dfs(int rr)

    {

           int longs=V[rr].size(), i, j;

           if(longs==0)

           {

                  dp[rr][0]=0;

                  dp[rr][1]=1;

                  return ;

           }

           else

           {

                  for(i=0; i<longs; i++)

                  {

                         dfs(V[rr][i]);

                         dp[rr][0]=0;

                         dp[rr][1]=1;

                         for(j=0; j<longs; j++)

                         {

                                dp[rr][0]+=dp[V[rr][j]][1];

                                dp[rr][1]+=min(dp[V[rr][j]][0], dp[V[rr][j]][1]);

                         }

                  }

           }

    }

    int main()

    {

           int n, i, j, son[1505], sonnum, ff, root, ss;

           while(scanf("%d", &n)!=EOF)

           {

                  memset(son, 0, sizeof(son));

                  memset(dp, 0, sizeof(dp));

                  for(i=0; i<n; i++)

                         V[i].clear();

                  for(i=0; i<n; i++)

                  {

                         scanf("%d:(%d)", &ff, &sonnum);

                         for(j=0; j<sonnum; j++)

                         {

                                scanf("%d", &ss);

                                son[ss]=1;

                                V[ff].push_back(ss);

                         }

                  }

                  for(i=0; i<n; i++)

                         if(!son[i])

                         {

                                root=i;

                                break;

                         }

                  dfs(root);

                  printf("%d\n", min(dp[root][1], dp[root][0]));

           }

    }

  • 相关阅读:
    Servlet和Filter的url匹配
    iterator的用法
    python学习笔记
    python的序列之列表
    java开发实战学习笔记3
    java学习笔记4
    Java Java集合
    Struts2中的几个符号
    DbHelper.cs
    做word,excel时需要引用com
  • 原文地址:https://www.cnblogs.com/Hilda/p/2617242.html
Copyright © 2020-2023  润新知