• 1050. String Subtraction (20)


    Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

    Input Specification:

    Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

    Output Specification:

    For each test case, print S1 - S2 in one line.

    Sample Input:
    They are students.
    aeiou
    
    Sample Output:
    Thy r stdnts.
    

    磕磕绊绊,也算过去了,加油!!


    #include <iostream>
    #include <map>
    #include <queue>
    #include <stdio.h>
    #include <vector>
    #include <algorithm>
    #include <stack>
    #include <stdlib.h>
    #include <string.h>
    #include <math.h>
    #include <string>
    using namespace std;
    
    #include<iostream>
    #include<vector>
    
    int has[10000];
    
    int main(){
    //	freopen("C:\Users\Administrator\Desktop\in.txt","r",stdin);
    	string s;
    	string c;
    	while(getline(cin,s)){
    		memset(has,0,sizeof(has));
    		getline(cin,c);
    		int ls=s.length();
    		int lc=c.length();
    		string temp="";
    		int flag=0;
    		for(int i=0;i<lc;i++){
    			has[c[i]]=1;
    		}
    		for(int j=0;j<ls;j++){
    			if(has[s[j]]==0){
    				temp+=s[j];
    			}
    		}
    		cout<<temp<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    session_id 生成原理
    压缩后的数据 要经过 base64_encode 后才能在网络上传送
    MySQL ANALYZE TABLE
    mysql 优化2
    mysql 查询优化
    第归调用
    『GoLang』函数
    『GoLang』控制结构
    『GoLang』语法基础
    『Python』装饰器
  • 原文地址:https://www.cnblogs.com/zh9927/p/4099044.html
Copyright © 2020-2023  润新知