• Triangular Pastures


    Description

    Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 

    I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length. 

    Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments. 

    Input

    * Line 1: A single integer N 

    * Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique. 

    Output

    A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed. 

    Sample Input

    5
    1
    1
    3
    3
    4
    

    Sample Output

    692
    

    Hint

    [which is 100x the area of an equilateral triangle with side length 4]
    题意:要构成三角形的牧场,当构成一个时,在接下来的变长再继续构,得到最大的面积,先得到所有可能的情况,在进行背包——海伦公式 p=(a+b+c)/2;S = sqrt(p*(p-a)*(p-b)*(p-c));貌似这道题看作边长越大面积越大...背包问题就是一种从最大开始数的情况.
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<iostream>
    using namespace std;
    int dp[1000][1000];
    int main(){
        int n,res = 0,mx = -1;
        int a[50];
        scanf("%d",&n);
        for(int i = 1; i <= n; i++){
            scanf("%d", &a[i]);
            res+=a[i];}
            int half = res>>1;
        memset(dp,0,sizeof(dp));
        dp[0][0] = 1;
        for(int i = 1; i <= n;i++)
            for(int j = half; j >=0;j--)
                for(int k = j; k >= 0; k--)
                    if(j >= a[i]&&dp[j-a[i]][k]||k>=a[i]&&dp[j][k-a[i]])//得到可能性的边
                         dp[j][k] = 1;
            for(int i = half;i >= 1;i--){
                for(int j = i;j >= 1;j--){
                    if(dp[i][j]){
                         int k = res - i - j;
                        if(i+j>k && i+k>j&& k+j>i){
                            double p = 1.0*(j+k+i)/2;
                         int S = (int)(sqrt(p*(p-i)*(p-j)*(p-k))*100);
                        if(S>mx)
                            mx = S;
                        }
                    }
                }
            }
            printf("%d",mx);
        return 0;
    }
    View Code
  • 相关阅读:
    [bzoj4408][Fjoi2016]神秘数
    BZOJ1102: [POI2007]山峰和山谷Grz
    BZOJ1098: [POI2007]办公楼biu
    BZOJ1097: [POI2007]旅游景点atr
    GDOI2018 新的征程
    BZOJ2084: [Poi2010]Antisymmetry
    回文树详解
    Codeforces739E. Gosha is hunting
    一道题17
    LOJ#6002. 「网络流 24 题」最小路径覆盖
  • 原文地址:https://www.cnblogs.com/zero-begin/p/4313372.html
Copyright © 2020-2023  润新知