• HDOJ/HDU 1062 Text Reverse(字符串翻转~)


    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.

    Output
    For each test case, you should output the text which is processed.

    Sample Input
    3
    olleh !dlrow
    m’I morf .udh
    I ekil .mca

    Sample Output
    hello world!
    I’m from hdu.
    I like acm.

    Hint
    Remember to use getchar() to read ‘ ’ after the interger T, then you may use gets() to read a line and process it.

    题意:
    输入一行字符串,将每一个单词(只有空格隔开)倒序输出!

    注意:
    开始和结尾可能有多个空格,单词之间可能有多个空格!

    PE的请注意:空格必须照原样输出!有几个输出几个,不能多输出也不能少输出!

    import java.util.Scanner;
    
    /**
     * @author 陈浩翔
     * 2016-5-25
     */
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t =sc.nextInt();
            sc.nextLine();//读取输入t之后的回车
            while(t-->0){
                String str=sc.nextLine();
                String s[] = str.split(" ");
                String str2="";
                for(int i=0;i<s.length;i++){
                    for(int k=s[i].length()-1;k>=0;k--){
                        System.out.print(s[i].charAt(k));
                        str2+=s[i].charAt(k);
                    }
                    if(i!=s.length-1){
                        System.out.print(" ");
                        str2+=" ";
                    }
                }
                for(int i=str2.length();i<str.length();i++){
                    System.out.print(" ");
                }
    
                System.out.println();
            }
        }
    }
    
  • 相关阅读:
    Windows下自动解压windows share上的文件
    Jenkins有用的插件
    windows下用时间戳创建文件名
    Jenkins Pulgin 安装
    安装在Linux下的jenkins执行windows下的bat命令
    Linux Shell下执行sqlplus
    Linux 下访问Windows共享目录
    Linux SSH 无密码登录
    Linux 文件编码问题及iconv命令
    Python抓取网页并保存为PDF
  • 原文地址:https://www.cnblogs.com/webmen/p/5739162.html
Copyright © 2020-2023  润新知