Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
Sample Input
Sample Output
8
984
1
Code
#include <stdio.h>
#include <math.h>
//二分法求解
//a^b = (a ^ (b/2))^2
int GetPow(int a,int b)
{
if(b==1||b==0)
{
return a;
}
if(b%2)
{
return ((int)(pow((float)GetPow(a,b/2),2)*a)%1000);
}
else
{
return ((int)(pow((float)GetPow(a,b/2),2))%1000);
}
}
int main()
{
int a,b;
while(scanf("%d%d",&a,&b)&&a!=0&&b!=0)
{
printf("%d\n",GetPow(a%=1000,b));
}
return 0;
}
Code
//网友 清香白莲 写的
#include <stdio.h>
int main()
{
unsigned int b, p, res, tmp;
while (scanf("%d %d", &b, &p) != EOF && (b || p))
{
res = 1;
b %= 1000;
tmp = b;
do
{
if (p & 0x1)
res = res * tmp % 1000;
tmp = tmp * tmp % 1000;
} while (p >>= 1);
printf("%d\n", res);
}
return 0;
}
原题出处:http://acm.hdu.edu.cn/showproblem.php?pid=2035