• HDU 5901 Count primes 论文题


    Count primes

    题目连接:

    http://acm.split.hdu.edu.cn/showproblem.php?pid=5901

    Description

    Easy question! Calculate how many primes between [1...n]!

    Input

    Each line contain one integer n(1 <= n <= 1e11).Process to end of file.

    Output

    For each case, output the number of primes in interval [1...n]

    Sample Input

    2
    3
    10

    Sample Output

    1
    2
    4

    Hint

    题意

    求[1,n]的素数有多少个

    题解:

    论文题,如果你没有做过类似的题目,那基本上就死翘翘了。。。

    据说可以分段打表?

    代码

    #include<bits/stdc++.h>
    using namespace std;
    
    #define MAXN 100
    #define MAXM 50010
    #define MAXP 166666
    #define MAX 1000010
    #define clr(ar) memset(ar, 0, sizeof(ar))
    #define read() freopen("lol.txt", "r", stdin)
    #define dbg(x) cout << #x << " = " << x << endl
    #define chkbit(ar, i) (((ar[(i) >> 6]) & (1 << (((i) >> 1) & 31))))
    #define setbit(ar, i) (((ar[(i) >> 6]) |= (1 << (((i) >> 1) & 31))))
    #define isprime(x) (( (x) && ((x)&1) && (!chkbit(ar, (x)))) || ((x) == 2))
    
    using namespace std;
    
    namespace pcf{
        long long dp[MAXN][MAXM];
        unsigned int ar[(MAX >> 6) + 5] = {0};
        int len = 0, primes[MAXP], counter[MAX];
    
        void Sieve(){
            setbit(ar, 0), setbit(ar, 1);
            for (int i = 3; (i * i) < MAX; i++, i++){
                if (!chkbit(ar, i)){
                    int k = i << 1;
                    for (int j = (i * i); j < MAX; j += k) setbit(ar, j);
                }
            }
    
            for (int i = 1; i < MAX; i++){
                counter[i] = counter[i - 1];
                if (isprime(i)) primes[len++] = i, counter[i]++;
            }
        }
    
        void init(){
            Sieve();
            for (int n = 0; n < MAXN; n++){
                for (int m = 0; m < MAXM; m++){
                    if (!n) dp[n][m] = m;
                    else dp[n][m] = dp[n - 1][m] - dp[n - 1][m / primes[n - 1]];
                }
            }
        }
    
        long long phi(long long m, int n){
            if (n == 0) return m;
            if (primes[n - 1] >= m) return 1;
            if (m < MAXM && n < MAXN) return dp[n][m];
            return phi(m, n - 1) - phi(m / primes[n - 1], n - 1);
        }
    
        long long Lehmer(long long m){
            if (m < MAX) return counter[m];
    
            long long w, res = 0;
            int i, a, s, c, x, y;
            s = sqrt(0.9 + m), y = c = cbrt(0.9 + m);
            a = counter[y], res = phi(m, a) + a - 1;
            for (i = a; primes[i] <= s; i++) res = res - Lehmer(m / primes[i]) + Lehmer(primes[i]) - 1;
            return res;
        }
    }
    
    int main()
    {
        pcf::init();
        long long n;
        while(cin>>n)
        cout<<pcf::Lehmer(n)<<endl;
    }
  • 相关阅读:
    DS博客作业03--树
    DS博客作业02--栈和队列
    DS博客作业02--线性表
    c博客06-结构体&文件
    c博客作业-指针
    C语言博客作业04--数组
    C语言博客作业03--函数
    图书馆
    5-互评-OO之接口-DAO模式代码阅读及应用.xls
    DS博客作业04--图
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5890939.html
Copyright © 2020-2023  润新知