• P3110 [USACO14DEC]驮运Piggy Back


    题目描述

    Bessie and her sister Elsie graze in different fields during the day, and in the evening they both want to walk back to the barn to rest. Being clever bovines, they come up with a plan to minimize the total amount of energy they both spend while walking.

    Bessie spends B units of energy when walking from a field to an adjacent field, and Elsie spends E units of energy when she walks to an adjacent field. However, if Bessie and Elsie are together in the same field, Bessie can carry Elsie on her shoulders and both can move to an adjacent field while spending only P units of energy (where P might be considerably less than B+E, the amount Bessie and Elsie would have spent individually walking to the adjacent field). If P is very small, the most energy-efficient solution may involve Bessie and Elsie traveling to a common meeting field, then traveling together piggyback for the rest of the journey to the barn. Of course, if P is large, it may still make the most sense for Bessie and Elsie to travel

    separately. On a side note, Bessie and Elsie are both unhappy with the term "piggyback", as they don't see why the pigs on the farm should deserve all the credit for this remarkable form of

    transportation.

    Given B, E, and P, as well as the layout of the farm, please compute the minimum amount of energy required for Bessie and Elsie to reach the barn.

    Bessie 和 Elsie在不同的区域放牧,他们希望花费最小的能量返回谷仓。从一个区域走到一个相连区域,Bessie要花费B单位的能量,Elsie要花费E单位的能量。

    如果某次他们两走到同一个区域,Bessie 可以背着 Elsie走路,花费P单位的能量走到另外一个相连的区域。当然,存在P>B+E的情况。

    相遇后,他们可以一直背着走,也可以独立分开。

    输入输出格式

    输入格式:

    INPUT: (file piggyback.in)

    The first line of input contains the positive integers B, E, P, N, and M. All of these are at most 40,000. B, E, and P are described above. N is the number of fields in the farm (numbered 1..N, where N >= 3), and M is the number of connections between fields. Bessie and Elsie start in fields 1 and 2, respectively. The barn resides in field N.

    The next M lines in the input each describe a connection between a pair of different fields, specified by the integer indices of the two fields. Connections are bi-directional. It is always possible to travel from field 1 to field N, and field 2 to field N, along a series of such connections.

    输出格式:

    OUTPUT: (file piggyback.out)

    A single integer specifying the minimum amount of energy Bessie and

    Elsie collectively need to spend to reach the barn. In the example

    shown here, Bessie travels from 1 to 4 and Elsie travels from 2 to 3

    to 4. Then, they travel together from 4 to 7 to 8.

    输入输出样例

    输入样例#1: 复制
    4 4 5 8 8 
    1 4 
    2 3 
    3 4 
    4 7 
    2 5 
    5 6 
    6 8 
    7 8 
    输出样例#1: 复制
    22 


    三次bfs
    #include <bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define inf 2147483647
    const ll INF = 0x3f3f3f3f3f3f3f3fll;
    #define ri register int
    template <class T> inline T min(T a, T b, T c)
    {
        return min(min(a, b), c);
    }
    template <class T> inline T max(T a, T b, T c)
    {
        return max(max(a, b), c);
    }
    template <class T> inline T min(T a, T b, T c, T d)
    {
        return min(min(a, b), min(c, d));
    }
    template <class T> inline T max(T a, T b, T c, T d)
    {
        return max(max(a, b), max(c, d));
    }
    #define pi acos(-1)
    #define me(x, y) memset(x, y, sizeof(x));
    #define For(i, a, b) for (int i = a; i <= b; i++)
    #define FFor(i, a, b) for (int i = a; i >= b; i--)
    #define mp make_pair
    #define pb push_back
    const int maxn = 100005;
    #define mod 100003
    const int N=100005;
    
    // name*******************************
    int v1[N],v2[N],v3[N];
    int dis[5][N];
    int vis[N];
    struct edge
    {
        int to,next;
    } e[N];
    queue<int>que;
    int tot=0;
    int Head[N];
    int B,E,P;
    int n,m;
    int ans=inf;
    // function******************************
    void add(int u,int v)
    {
        e[++tot].to=v;
        e[tot].next=Head[u];
        Head[u]=tot;
    }
    
    void bfs(int x)
    {
        int y;
        if(x==1)y=1;
        if(x==2)y=2;
        if(x==n)y=3;
        me(vis,0);
        que.push(x);
        vis[x]=1;
        while(!que.empty())
        {
            int u=que.front();
            que.pop();
            for(int p=Head[u]; p; p=e[p].next)
            {
                int v=e[p].to;
                if(vis[v])continue;
                dis[y][v]=dis[y][u]+1;
                vis[v]=1;
                que.push(v);
            }
        }
    }
    
    //***************************************
    int main()
    {
        ios::sync_with_stdio(0);
    //    cin.tie(0);
        //    freopen("test.txt", "r", stdin);
        cin>>B>>E>>P>>n>>m;
        For(i,1,m)
        {
            int a,b;
            cin>>a>>b;
            add(a,b);
            add(b,a);
        }
        bfs(1);
        bfs(2);
        bfs(n);
        For(i,1,n)
        {
    //        cout<<v1[i]*B+v2[i]*E+v3[i]*P<<endl;
            ans=min(ans,dis[1][i]*B+dis[2][i]*E+dis[3][i]*P);
        }
        cout<<ans;
        return 0;
    }
  • 相关阅读:
    react实现登陆页面
    “css中设置边框不显示,border:none; 和border:0; 都没用”的解决方案
    JQuery AJAX的post()方法和get()方法的区别
    JQuery事件之文档/窗口事件
    JQuery事件之表单事件
    【K8S初识】-什么是Kubernetes
    Yaml语法理解
    Json语法理解
    Maven学习-Maven工程中默认的环境变量
    Java语言(7)-Java中的注解
  • 原文地址:https://www.cnblogs.com/planche/p/8665737.html
Copyright © 2020-2023  润新知