• POJ 2503 Babelfish


    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops
    

    Hint

    Huge input and output,scanf and printf are recommended.
     
    解题思路:
    题目很简单,map直接过,就是输入让人有点摸不到头脑,怎么输入,可以直接算这一行的长度,还可以读取 啥的各种姿势。
    #include<iostream>
    #include<cstring>
    #include<string>
    #include<map>
    #include<stdio.h>
    using namespace std;
     
    int main()
    {
        map<string,string> d;
        char str1[12],str2[12],str[30];
           while(gets(str))
           {
               if(strlen(str)==0)
               break;
               sscanf(str,"%s %s",str1,str2);
               d[str2]=str1;
           }
           string str3,p_out;
           while(cin>>str3)
           {
               p_out=d[string(str3)];
               if(p_out.length()==0)
               cout<<"eh"<<endl;
               else
               cout<<p_out<<endl;
           }
           return 0;
    }
  • 相关阅读:
    在vmware workstation10上安装ubuntu14.04,出现以下问题
    经典句
    杂文
    matlab里textread出现错误“Trouble reading floating point number from file (row 1, field 1)”
    Nginx配置杂记(转)
    mysql经典案例分析
    Git查看、删除、重命名远程分支和tag(转)
    nginx下开启pathinfo模式
    ubuntu-apache如何解决跨域资源访问
    c语言插入排序
  • 原文地址:https://www.cnblogs.com/kls123/p/7127007.html
Copyright © 2020-2023  润新知