• Fence Repair (二叉树求解)(优先队列,先取出小的)


    题目链接:http://poj.org/problem?id=3253

    Fence Repair
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 61005   Accepted: 20119

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
     
    题目大意:将一块很长的木板切割成n块,每块的长度为a[i]  未切割前木板的长度恰好为切割后木板长度的总和。 每次切割木板时,需要开销为这块木板的长度。 例如长度为21的木板切割成
    长度为5 8 8的三块木板。长度为21的木板切割成13 8的两块,需要开销21 ,长度为13的木板切割成5 8的两块木板,需要开销为13 ,所以总共要34。    问你切割木板所需要的最小开销是多少?
    思路:由于切割木板的顺序不确定,自由度很高,这个题目貌似很难入手。  其实呢, 只要每次都找最小的两块木板,把新生成的木板加入进去就行了,一直循环此过程,就是最优解
    那么为什么呢??   其实就是一颗二叉树,因为不管你怎么选叶子节点的个数都是一样的(就是n块木板) 该木板所需的花费刚好为该节点的值*该节点的深度,那么是不是越小的放在越下面
    花费金额越少呢??   就是这样了,看代码
    #include<iostream>
    #include<string.h>
    #include<map>
    #include<cstdio>
    #include<cstring>
    #include<stdio.h>
    #include<cmath>
    #include<math.h>
    #include<algorithm>
    #include<set>
    #include<queue>
    typedef long long ll;
    using namespace std;
    const ll mod=1e9+7;
    const int maxn=2e4+10;
    const int maxk=1e4+10;
    const int maxx=1e4+10;
    const ll maxe=1000+10;
    #define INF 0x3f3f3f3f3f3f
    #define Lson l,mid,rt<<1
    #define Rson mid+1,r,rt<<1|1
    int n;
    int a[maxn];
    void solve()
    {
        ll ans=0;
        while(n>1)
        {
            int mi1=0,mi2=1;
            if(a[mi1]>a[mi2]) swap(mi1,mi2);
            for(int i=2;i<n;i++)
            {
                if(a[i]<a[mi1])
                {
                    mi2=mi1;
                    mi1=i;
                }
                else if(a[i]<a[mi2])
                {
                    mi2=i;
                }
            }
            int l=a[mi1]+a[mi2];
            ans+=l;
            if(a[mi1]==n-1) swap(mi1,mi2);
            a[mi1]=l;
            a[mi2]=a[n-1];
            n--;
        }
        cout<<ans<<endl;
    }
    int main()
    {
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        sort(a,a+n);
        solve();
        return 0;
    }

    上面的算法复杂度是n*n,其实还有一种更快的方法,原理跟上面的一样,但是下面的算法用到优先队列,所以把复杂度降到nlogn

    看代码

    #include<iostream>
    #include<string.h>
    #include<map>
    #include<cstdio>
    #include<cstring>
    #include<stdio.h>
    #include<cmath>
    #include<math.h>
    #include<algorithm>
    #include<set>
    #include<queue>
    typedef long long ll;
    using namespace std;
    const ll mod=1e9+7;
    const int maxn=2e4+10;
    const int maxk=1e4+10;
    const int maxx=1e4+10;
    const ll maxe=1000+10;
    #define INF 0x3f3f3f3f3f3f
    #define Lson l,mid,rt<<1
    #define Rson mid+1,r,rt<<1|1
    int n;
    int a[maxn];
    priority_queue<int,vector<int>,greater<int> >que;//声明一个从小到大取出数值的优先队列
    void solve()
    {
        ll ans=0;
        for(int i=0;i<n;i++)
            que.push(a[i]);//全部存入队列
        while(n>1)
        {
            int l1,l2;
            l1=que.top();
            que.pop();
            l2=que.top();
            que.pop();
            int t=l1+l2;
            ans+=t;
            que.push(t);
            n--;
        }
        cout<<ans<<endl;
    }
    int main()
    {
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
       // sort(a,a+n);
        solve();
        return 0;
    }
    当初的梦想实现了吗,事到如今只好放弃吗~
  • 相关阅读:
    codevs1231 最优布线问题
    P1352 没有上司的舞会——树形DP入门
    codevs1961 躲避大龙
    codevs2833 奇怪的梦境
    linux 内存管理——内核的shmall 和shmmax 参数
    删除共享内存后key为0x00000000的问题
    redis命令之lrange
    vim配置vimrc详解
    chmod chgrp chown
    localtime和localtime_r
  • 原文地址:https://www.cnblogs.com/caijiaming/p/9417819.html
Copyright © 2020-2023  润新知