• I


    I - Doing Homework again
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    Description

    Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
     

    Input

    The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
    Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 
     

    Output

    For each test case, you should output the smallest total reduced score, one line per test case. 
     

    Sample Input

    3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
     

    Sample Output

    0 3 5
    my answer:
    #include<iostream>
    #include<algorithm>
    using namespace std;
    typedef struct st{
        int day;
        int score;
    }st;
    bool cmp(st a,st b){
        return a.score>b.score;
    }
    int main()
    {
        int n,T;
        cin>>T;
        while(cin>>n)
        {
            st a[1000];
            int vis[1000]={0};
            for(int i=0;i!=n;i++)
                cin>>a[i].day;
            for(int i=0;i!=n;i++)
                cin>>a[i].score;
            int b[1000];
            sort(a,a+n,cmp);
            int sum=0;
            for(int j=0;j<n;j++){
                if(vis[a[j].day]){
                	
                    int k=a[j].day;
                    while(k>0&&vis[k])k--;
                    if(k<=0){sum+=a[j].score;}
                    else vis[k]=1;
                }
    			else
    		    {
                    vis[a[j].day]=1;
                }
            }
            cout<<sum<<endl;
        }
        return 0;
    }


  • 相关阅读:
    Html5——视频标签使用
    Android的四大组件
    Android 硬编码
    按键事件处理
    android Keycode 完全对照表
    Activity的生命周期
    音乐播放控制
    Android permission 访问权限大全
    制作留言板相关资料
    adb查询log命令
  • 原文地址:https://www.cnblogs.com/NYNU-ACM/p/4248805.html
Copyright © 2020-2023  润新知