• Light OJ 1296:Again Stone Game(SG函数打表找规律)


    Alice and Bob are playing a stone game. Initially there are n piles of stones and each pile contains some stone. Alice stars the game and they alternate moves. In each move, a player has to select any pile and should remove at least one and no more than half stones from that pile. So, for example if a pile contains 10 stones, then a player can take at least 1 and at most 5 stones from that pile. If a pile contains 7 stones; at most 3 stones from that pile can be removed.

    Both Alice and Bob play perfectly. The player who cannot make a valid move loses. Now you are given the information of the piles and the number of stones in all the piles, you have to find the player who will win if both play optimally.

    Input

    Input starts with an integer T (≤ 100), denoting the number of test cases.

    Each case starts with a line containing an integer n (1 ≤ n ≤ 1000). The next line contains n space separated integers ranging in [1, 109]. The ith integer in this line denotes the number of stones in the ith pile.

    Output

    For each case, print the case number and the name of the player who will win the game.

    Sample Input

    5

    1

    1

    3

    10 11 12

    5

    1 2 3 4 5

    2

    4 9

    3

    1 3 9

    Sample Output

    Case 1: Bob

    Case 2: Alice

    Case 3: Alice

    Case 4: Bob

    Case 5: Alice

    题意

    有n堆石子,每堆ai个,Alice和Bob两人取石子,可以任选一堆取,每次至少一个至多ai/2个(奇数情况向下取整)。最后不能取石子的人失败

    思路

    数据范围1e9,肯定不能打表计算,但是可以打表来找一下规律。最后会发现,如果ai是偶数的话,可以把这堆石子看成ai/2个石子进行取,如果是奇数,就让ai一直除以2,至到找到偶数,然后再按照石子数是偶数的情况处理一下就可以了

    AC代码

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <set>
    #include <string>
    #define ll long long
    #define ull unsigned long long
    #define ms(a) memset(a,0,sizeof(a))
    #define pi acos(-1.0)
    #define INF 0x7f7f7f7f
    #define lson o<<1
    #define rson o<<1|1
    const double E=exp(1);
    const int maxn=1e6+10;
    const int mod=1e9+7;
    using namespace std;
    int SG[1005], mex[1005];
    int sg[maxn];
    int vis[maxn];
    int a[maxn];
    inline void getSG()
    {
    	ms(sg);
    	for(register int i=1;i<=maxn;i++)
    	{
    		ms(vis);
    		for(int j=1;2*j<=i;j++)
    			vis[sg[i-j]]=1;
    		for(register int j=0;j<=maxn;j++)
    		{
    			if(!vis[j])
    			{
    				sg[i]=j;
    				break;
    			}
    		}
    		cout<<i<<"======="<<sg[i]<<endl;
    	}
    }
    int main(int argc, char const *argv[])
    {
    	// getSG();
    	ios::sync_with_stdio(false);
    	register int t;
    	register int _=0;
    	register int n;
    	cin>>t;
    	while(t--)
    	{
    		register int sum=0,x;
    		cin>>n;
    		while(n--)
    		{
    			cin>>x;
    			while(x%2!=0)
    				x/=2;
    			x/=2;
    			sum^=x;
    		}
    		cout<<"Case "<<++_<<": ";
    		if(sum)
    			cout<<"Alice"<<endl;
    		else
    			cout<<"Bob"<<endl;
    	}
    	return 0;
    }
  • 相关阅读:
    在线添加磁盘,扩展LVM卷案例
    iOS 通过代码关闭应用程序
    hdu1443(约瑟夫环游戏的原理 用链表过的)
    Mapper映射语句高阶应用——ResultMap
    SeekBar和RatingBar
    Myeclipse中如何修改Tomcat的端口号
    新浪微博客户端开发之OAuth认证篇
    层层递进Struts1(六)自定义转换器
    CF 13E Holes 【块状链表】
    《mysql必知必会》学习_第13章
  • 原文地址:https://www.cnblogs.com/Friends-A/p/10324351.html
Copyright © 2020-2023  润新知