• hdu1250(Java)大数相加的问题


    Hat's Fibonacci

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10525 Accepted Submission(s): 3483


    Problem Description
    A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
    F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
    Your task is to take a number as input, and print that Fibonacci number.
     
    Input
    Each line will contain an integers. Process to end of file.
     
    Output
    For each case, output the result in a line.
     
    Sample Input
    100
     
    Sample Output
    4203968145672990846840663646

    -------------------------------------------------

    import java.math.BigDecimal;
    import java.util.Scanner;

    public class Main1250{
    public static void main(String args[]){
    Scanner cin=new Scanner(System.in);
    BigDecimal []a=new BigDecimal[10007];
    a[0]=new BigDecimal(1);
    a[1]=new BigDecimal(1);
    a[2]=new BigDecimal(1);
    a[3]=new BigDecimal(1);
    for(int i=4;i<10007;i++)
    a[i]=a[i-1].add(a[i-2]).add(a[i-3]).add(a[i-4]);
    while(cin.hasNext()){
    int n=cin.nextInt();
    System.out.println(a[n-1]);

    }
    }
    }

    ----------------- 

    Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
     

    这个地方要注意数组要开大点,题目不是说只有2005个数

  • 相关阅读:
    VMWare安装Win10虚拟机 昆明
    c#游戏进程杀手 昆明
    图解机器学习读书笔记CH2
    深度学习中的线性代数知识详解
    图解机器学习读书笔记CH1
    三分算法
    POJ 2356 Find a multiple【抽屉原理】
    POJ 1170 Shoping Offers(IOI 95)
    HDU 2438 Turn the corner【三分】
    HDU 3552 I can do it! 【贪心】
  • 原文地址:https://www.cnblogs.com/1314wamm/p/5679622.html
Copyright © 2020-2023  润新知