• ZOJ 3869 Ace of Aces


    There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

    After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

    Please write program to help TSAB determine who will be the "Ace of Aces".

    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

    Output

    For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

    Sample Input

    3
    5
    2 2 2 1 1
    5
    1 1 2 2 3
    1
    998
    

    Sample Output

    2
    Nobody
    998
    ——————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————

    2015浙江省赛的题目其中一题,不是很难。
    题意:给出n张选票,算出得票数最多的人的id,如果有2个及以上的人都获得了最多的选票,则输出Nobody。
    思路:计数题。设一个结构体,最后按照票数来排序即可。

    #include<iostream>
    #include<string>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    struct node
    {
        int id;
        int cnt;
    }a[1005];
    
    bool cmp(node a, node b)
    {
        return a.cnt > b.cnt;
    }
    
    int main()
    {
        //freopen("D:\txt.txt", "r", stdin);
        int n;
        while (cin >> n)
        {
            while (n--)
            {
                memset(a, 0, sizeof(a));
                int t,m;
                int maxn = 0;
                cin >> t;
                for (int i = 0; i < t; i++)
                {
                    cin >> m;
                    a[m].id = m;
                    a[m].cnt++;
                }
                sort(a, a + 1000, cmp);
                if (a[0].cnt == a[1].cnt)  cout << "Nobody" << endl;
                else cout << a[0].id<<endl;
            }
        }
    }
  • 相关阅读:
    HDFS文件系统上传时序图 PB级文件存储时序图
    HDFS 文件系统流程图。PB级文件存储时序图。
    HBase 1.1.2 优化插入 Region预分配
    InputStream、OutputStream
    StringBuffer_StringBuilder
    java中的字符串
    升级的三个因素
    装饰设计模式
    IO字符流之读写缓冲区(BufferedWriter、BufferedReader)
    IO(FileWriter/FileReader)字符流:文件的写入、续写、读
  • 原文地址:https://www.cnblogs.com/zyb993963526/p/6344976.html
Copyright © 2020-2023  润新知