• HDOJ 5384 Danganronpa AC自己主动机



     AC自己主动机裸题

    Danganronpa

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 164    Accepted Submission(s): 80


    Problem Description
    Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

    Now, Stilwell is playing this game. There are n verbal evidences, and Stilwell has m "bullets". Stilwell will use these bullets to shoot every verbal evidence.

    Verbal evidences will be described as some strings Ai, and bullets are some strings Bj. The damage to verbal evidence Ai from the bullet Bj is f(Ai,Bj).
    f(A,B)=i=1|A||B|+1[ A[i...i+|B|1]=B ]
    In other words, f(A,B) is equal to the times that string B appears as a substring in string A.
    For example: f(ababa,ab)=2f(ccccc,cc)=4

    Stilwell wants to calculate the total damage of each verbal evidence Ai after shooting all m bullets Bj, in other words is mj=1f(Ai,Bj).
     

    Input
    The first line of the input contains a single number T, the number of test cases.
    For each test case, the first line contains two integers nm.
    Next n lines, each line contains a string Ai, describing a verbal evidence.
    Next m lines, each line contains a string Bj, describing a bullet.

    T10
    For each test case, n,m1051|Ai|,|Bj|104|Ai|105|Bj|105
    For all test case, |Ai|6105|Bj|6105Ai and Bj consist of only lowercase English letters
     

    Output
    For each test case, output n lines, each line contains a integer describing the total damage of Ai from all m bullets, mj=1f(Ai,Bj).
     

    Sample Input
    1 5 6 orz sto kirigiri danganronpa ooooo o kyouko dangan ronpa ooooo ooooo
     

    Sample Output
    1 1 0 3 7
     

    Source
     

    /* ***********************************************
    Author        :CKboss
    Created Time  :2015年08月13日 星期四 13时55分22秒
    File Name     :1005.cpp
    ************************************************ */
    
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <string>
    #include <cmath>
    #include <cstdlib>
    #include <vector>
    #include <queue>
    #include <set>
    #include <map>
    
    using namespace std;
    
    typedef long long int LL;
    
    const int maxn=110100;
    
    int ch[maxn][26],fail[maxn];
    LL End[maxn];
    int root,sz;
    
    int newnode()
    {
        memset(ch[sz],-1,sizeof(ch[sz]));
        End[sz++]=0;
        return sz-1;
    }
    
    void init()
    {
        sz=0; root=newnode();
    }
    
    void insert(const char str[])
    {
        int len=strlen(str);
        int now=root;
        for(int i=0;i<len;i++)
        {
            int& temp=ch[now][str[i]-'a'];
            if(temp==-1) temp=newnode();
            now=temp;
        }
        End[now]++;
    }
    
    void build()
    {
        queue<int> q;
        fail[root]=root;
        for(int i=0;i<26;i++)
        {
            int &temp=ch[root][i];
            if(temp==-1) temp=root;
            else
            {
                fail[temp]=root;
                q.push(temp);
            }
        }
        while(!q.empty())
        {
            int now=q.front(); q.pop();
            for(int i=0;i<26;i++)
            {
                if(ch[now][i]==-1)
                {
                    ch[now][i]=ch[fail[now]][i];
                }
                else
                {
                    fail[ch[now][i]]=ch[fail[now]][i];
                    q.push(ch[now][i]);
                }
            }
        }
    }
    
    LL query(const char str[])
    {
        int len=strlen(str);
        int now=root;
        LL ret=0;
        for(int i=0;i<len;i++)
        {
            now=ch[now][str[i]-'a'];
            int temp=now;
            while(temp!=root)
            {
                ret+=End[temp];
                temp=fail[temp];
            }
        }
        return ret;
    }
    
    int n,m;
    string Ts[maxn],Tp[maxn];
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
    
        int T_T;
        scanf("%d",&T_T);
        while(T_T--)
        {
            scanf("%d%d",&n,&m);
            for(int i=0;i<n;i++) cin>>Ts[i];
    
            init();
            for(int i=0;i<m;i++) 
            {
                cin>>Tp[i];
                insert(Tp[i].c_str());
            }
    
            build();
    
            for(int i=0;i<n;i++)
            {
                LL as=query(Ts[i].c_str());
                cout<<as<<endl;
            }
        }
        
        return 0;
    }





  • 相关阅读:
    Netstat
    Ant+jmeter+jenkins搭建测试的持续集成
    一个不会写代码的测试员
    JMeter监控内存及CPU ——plugin插件监控被测系统资源方法
    Ant+jmeter 实现自动化性能测试
    selenium+jenkins网页自动化测试的构建
    JMeter分布式测试
    jmeter压力测试的简单实例+badboy脚本录制
    js倒计时
    容器
  • 原文地址:https://www.cnblogs.com/zhchoutai/p/8592825.html
Copyright © 2020-2023  润新知