• Hdu 1087 Super Jumping! Jumping! Jumping!


    Super Jumping! Jumping! Jumping!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 38157    Accepted Submission(s): 17500

    Problem Description

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

     

    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.

    Input

    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.

    Output

    For each case, print the maximum according to rules, and one line one case.

    Sample Input

    3 1 3 2

    4 1 2 3 4

    4 3 3 2 1

    0

    Sample Output

    4

    10

    3

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #define MAXN 1005
    using namespace std;
    int num[MAXN],m[MAXN];//m记录以每个终点的最长上升总和
    int main()
    {
        int t,i,j,k;
        while(cin>>t)
        {
            if(t==0)
                break;
            memset(m,0,sizeof(0));
            for(i=1;i<=t;i++)
                scanf("%d",&num[i]);
            m[1]=num[1];
            for(i=2;i<=t;i++)
            {
                m[i]=num[i];
                for(j=1;j<i;j++)
                {
                    if(num[j]<num[i])
                        m[i]=max(m[i],m[j]+num[i]);
                }
            }
            k=m[1];
            for(i=1;i<=t;i++)
                k=m[i]>k?m[i]:k;
            cout<<k<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    asp.net(.net 4.0)+ json 分页
    在两张表(A表和B表)里面找出A中不存在B表的记录
    linq to sql 的List<Table> 数据表缓存
    linq 并发冲突概念
    阿里RocketMq节约成本
    阿里巴巴java手册异常日志
    阿里巴巴java手册安全规约
    阿里巴巴java手册单元测试
    Spring boot自定义starter
    MongoDB权限
  • 原文地址:https://www.cnblogs.com/zhangliu/p/7057855.html
Copyright © 2020-2023  润新知