• HDU Exponentiation 1063 Java大数题解


    Exponentiation

    Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6973    Accepted Submission(s): 1975


    Problem Description
    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 
     

    Input
    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
     

    Output
    The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
     

    Sample Input
    95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
     

    Sample Output
    548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201


    大数的题目使用Java就变得其简单无比。

    主要就一句代码:

    String ans = a.pow(b).stripTrailingZeros().toPlainString();

    去零和转换为纯字符串输出。

    这使用C++要数十行代码。

    对照C++解法:http://blog.csdn.net/kenden23/article/details/23997827

    相比之下。java就成了水题了。学不到什么东西。

    import java.math.BigDecimal;
    import java.util.*;
    
    public class Main
    {
        public static void main(String[] args)
        {
            Scanner scan = new Scanner(System.in);
            while (scan.hasNext())
            {
                BigDecimal a = scan.nextBigDecimal();
                int b = scan.nextInt();
                String ans = a.pow(b).stripTrailingZeros().toPlainString();
                if (ans.startsWith("0")) ans = ans.substring(1);
                System.out.println(ans);
            }
            scan.close();
        }
    }



  • 相关阅读:
    (转)Dockerfile安全介绍
    (转)浅析Docker运行安全
    (转)网络安全设备默认密码
    docker kali 相关初始化工作
    hibernate(结合springboot)入门
    idea 通过 Generate POJOs.groovy 生成实体类
    linux jdk 安装
    docker pstgres安装
    使用docker搭建FastDFS文件系统
    [docker]离线环境导入镜像
  • 原文地址:https://www.cnblogs.com/yxwkf/p/5208095.html
Copyright © 2020-2023  润新知