• 杭电1013-Digitai Root(这是一道考研编程题-天大2015)


    Digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 53625    Accepted Submission(s): 16747


    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
     
    Input
    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
     
    Output
    For each integer in the input, output its digital root on a separate line of the output.
     
    Sample Input
    24
    39
    0
     
    Sample Output
    6
    3
     
    分析:
    1  10  19(10)  28(10)  ....
    2  11  20        29(11)
    3  12  21        30
    4  13  22       .....
    5  14  23
    6  15  24
    7  16  25
    8  17  26
    9  18  27
     
    #include<stdio.h>
    #include<string.h>
    int main(){
        long int sum,len,i;
        char num[10000];
        while(scanf("%s",num) && num[0]!='0'){
            
            len=strlen(num);
            sum=0;
            for(i=0;i<len;i++)
                sum+=num[i]-'0';
            sum=sum%9;
            if(sum>0)
                printf("%d ",sum%9);
            else
                printf("9 ");
        }
        return 0;
    }

  • 相关阅读:
    dada的GCD
    涛神的城堡
    手机信号
    涛涛的Party
    壮壮的数组
    不安全字符串
    gdb core 调试多线程
    makefile $@, $^, $<, $? 表示的意义
    KMP算法的next[]数组通俗解释
    【原创】支持同时生成多个main函数 makefile 模板
  • 原文地址:https://www.cnblogs.com/wft1990/p/4323704.html
Copyright © 2020-2023  润新知