• HDOJ/HDU 2700 Parity(奇偶判断~)


    Problem Description
    A bit string has odd parity if the number of 1’s is odd. A bit string has even parity if the number of 1’s is even.Zero is considered to be an even number, so a bit string with no 1’s has even parity. Note that the number of
    0’s does not affect the parity of a bit string.

    Input
    The input consists of one or more strings, each on a line by itself, followed by a line containing only “#” that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter ‘e’ or a lowercase letter ‘o’.

    Output
    Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was ‘e’) or odd parity (if the letter was ‘o’).

    Sample Input
    101e
    010010o
    1e
    000e
    110100101o
    #

    Sample Output
    1010
    0100101
    11
    0000
    1101001010

    英文题~看懂题意就ok了。
    e代表的是偶数奇偶性校验。
    o代表的是奇数奇偶性校验。
    0代表是。1代表否~
    其实就是判断1的个数~

    import java.util.Scanner;
    
    /**
     * @author 陈浩翔
     */
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc= new Scanner(System.in);
            while(sc.hasNext()){
                String str = sc.next();
                if(str.equals("#")){
                    return ;
                }
                int num=0;
                for(int i=0;i<str.length()-1;i++){
                    if(str.charAt(i)=='1'){
                        num++;
                    }
                }
                if(num%2==0){//1出现的次数为偶数
                    if(str.charAt(str.length()-1)=='e'){//偶数奇偶校验
                        //0代表判断正确
                        System.out.println(str.substring(0, str.length()-1)+'0');
                    }else{
                        System.out.println(str.substring(0, str.length()-1)+'1');
                    }
                }else{
                    if(str.charAt(str.length()-1)=='o'){//奇数奇偶校验
                        //0代表判断正确
                        System.out.println(str.substring(0, str.length()-1)+'0');
                    }else{
                        System.out.println(str.substring(0, str.length()-1)+'1');
                    }
                }
            }
        }
    }
    
  • 相关阅读:
    poj2502(最短路)
    poj1511(最小环和)
    uva11090(spfa判负环)
    hdu4370(spfa最短路最小环)
    uva10561(SG)
    uvalive5059(SG)
    uvaliva3905(扫描线)
    scu4445(模拟)
    uvalive3902(树上的最优化 贪心)
    scu4444(完全图最短路)
  • 原文地址:https://www.cnblogs.com/webmen/p/5739172.html
Copyright © 2020-2023  润新知