• Oil Deposits HDU 1241


    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

    InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
    OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0 

    Sample Output

    0
    1
    2
    2

    #include <bits/stdc++.h>
    using namespace std;
    #define M 102
    
    char map1[M][M];
    int vis[M][M];
    int m,n,sum;
    int dir[8][2] = {{1,0},{1,1},{0,1},{-1,1},{-1,0},{-1,-1},{0,-1},{1,-1}};
    
    void dfs(int x, int y){
    	for(int i = 0; i < 8; i++)
    	{
    		int dx = x + dir[i][0];
    		int dy = y + dir[i][1];
    		if(dx >= 0 && dy >= 0 && dx < m && dy < n && map1[dx][dy] == '@' && !vis[dx][dy]){
    			vis[dx][dy] = 1;
    			dfs(dx,dy);
    		}
    	}
    	return;
    }
    
    int main(){
    	while(cin>>m>>n && m && n){
    		memset(vis,0,sizeof(vis));
    		sum = 0;
    		getchar();
    		for(int i = 0; i < m; i++)
    			scanf("%s",map1[i]);
    		for(int i = 0; i < m; i++)
    			for(int j = 0; j < n; j++)
    				if(map1[i][j] == '@' && !vis[i][j]){
    					sum++;dfs(i,j);
    				}
    		cout<<sum<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    任何有模的计量器,均可化减法为加法运算
    定时器:4叉堆与2叉堆的效率比较_znHD的博客CSDN博客 https://blog.csdn.net/znzxc/article/details/85916740
    网络智能运维的升级 Telemetry vs SNMP
    供应链仿真体系建设实践
    【leetcode】链表的中间结点
    【leetcode】合并K个升序链表
    【leetcode】141. 环形链表 142. 环形链表 II
    [Leetcode]21. 合并两个有序链表
    【leetcode】19. 删除链表的倒数第 N 个结点
    [leetcode] 2055蜡烛之间的盘子 | 前缀和
  • 原文地址:https://www.cnblogs.com/stul/p/9987849.html
Copyright © 2020-2023  润新知