• 1027 Colors in Mars (20分)


    People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

    Input Specification:

    Each input file contains one test case which occupies a line containing the three decimal color values.

    Output Specification:

    For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

    Sample Input:

    15 43 71
    
     

    Sample Output:

    #123456


    10进制转13进制,用除法,且结果最多两位。
    所以可以使用一个字符串来存储每一位的结果
    将10进制的每一位用13进制来表示,然后去字符串中找对应的结果并输出


    #include<iostream>
    using namespace std;
    int main()
    {
        string a ={"0123456789ABC"};//用一个字符串来存储要输出的结果
        int num1,num2,num3;
        while(scanf("%d %d %d",&num1,&num2,&num3))
        {
            printf("#");
            printf("%c%c%c%c%c%c",a[num1/13],a[num1%13],a[num2/13],a[num2%13],a[num3/13],a[num3%13]);
        }
    
        return 0;
    }
  • 相关阅读:
    MySQL架构备份
    MySQL物理备份 xtrabackup
    MySQL物理备份 lvm-snapshot
    MySQL逻辑备份mysqldump
    MySQL逻辑备份into outfile
    MySQ数据备份
    前端基础-- HTML
    奇淫异巧之 PHP 后门
    php中代码执行&&命令执行函数
    windows进程中的内存结构(缓冲溢出原理)
  • 原文地址:https://www.cnblogs.com/qinmin/p/12902483.html
Copyright © 2020-2023  润新知