• 数学--数论--HDU1825(积性函数性质+和函数公式+快速模幂+非互质求逆元)


    As we all know, the next Olympic Games will be held in Beijing in 2008. So the year 2008 seems a little special somehow. You are looking forward to it, too, aren’t you? Unfortunately there still are months to go. Take it easy. Luckily you meet me. I have a problem for you to solve. Enjoy your time.

    Now given a positive integer N, get the sum S of all positive integer divisors of 2008 N. Oh no, the result may be much larger than you can think. But it is OK to determine the rest of the division of S by K. The result is kept as M.

    Pay attention! M is not the answer we want. If you can get 2008 M, that will be wonderful. If it is larger than K, leave it modulo K to the output. See the example for N = 1,K = 10000: The positive integer divisors of 20081 are 1、2、4、8、251、502、1004、2008,S = 3780, M = 3780, 2008 M % K = 5776.

    Input
    The input consists of several test cases. Each test case contains a line with two integers N and K (1 ≤ N ≤ 10000000, 500 ≤ K ≤ 10000). N = K = 0 ends the input file and should not be processed.
    Output
    For each test case, in a separate line, please output the result.
    Sample Input
    1 10000
    0 0
    Sample Output
    5776
    这个题跟HDU452一样,但是就是因为250跟其他数字不互质,所以没法求逆元,然后get到了一个公式。很nice。
    就是这个 x/d%m = x%(d*m)/d

    import java.util.Scanner;
    
    
    public class Main {
    	static long q_pow(long a,long b,long mod){
    	    long ans = 1;
    	    while(b!=0){
    	        if(b%2==1)
    	            ans = ans * a % mod;
    	        b >>= 1;
    	        a = a * a % mod;
    	    }
    	    return ans;
    	}
    	public static void main(String[] args) {
    		Scanner in=new Scanner(System.in);
    		int N,K;
    		while (in.hasNext()) {
    			
    			N=in.nextInt();
    			K=in.nextInt();
    			if(N==0&&K==0) break;
    			long m=(q_pow(2,3*N+1,250*K)-1)*(q_pow(251,N+1,250*K)-1)%(250*K)/250;
    			System.out.println(q_pow(2008,m,K));
    		}
    		
     
    	}
    
    } 
    
  • 相关阅读:
    ApacheServer-----关于443端口被占用的解决方法
    《小强与小明》——正在疯传的伟大的故事
    不争万年,只珍朝夕------我的态度
    dubbo搭建
    使用netty的第一个Hello World
    myBatis数据库常用标签
    mysql 索引
    tomcat部署项目的一点心得
    【康托展开】
    初探计算机硬盘
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12798500.html
Copyright © 2020-2023  润新知