• hdoj_1548A strange lift


    A strange lift

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7718    Accepted Submission(s): 2899


    Problem Description
    There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
    Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
     

    Input
    The input consists of several test cases.,Each test case contains two lines.
    The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
    A single 0 indicate the end of the input.
     

    Output
    For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
     

    Sample Input
    5 1 5 3 3 1 2 5 0
     

    Sample Output
    3
     

    BFS,注意设置个vis数组,去重。

    #include <iostream>
    #include <cstring>
    #include <queue>
    #include <cstdio>
    using namespace std;
    #pragma warning(disable : 4996)
    #define MAX 205
    
    typedef struct Node
    {
    	int x;
    	int cnt;
    }Node;
    Node floors[MAX];
    bool vis[MAX];
    int n;
    queue<Node>Q;
    
    int bfs(int x, int y)
    {
    	Node pre, next;
    	while (!Q.empty())
    	{
    		Q.pop();
    	}
    	pre.x = x;
    	pre.cnt = 0;
    	Q.push(pre);
    	while (!Q.empty())
    	{
    		pre = Q.front();
    		Q.pop();
    		if(pre.x == y)
    		{
    			return pre.cnt;
    		}
    		next.x = pre.x + floors[pre.x].x;
    		if(next.x >= 1 && next.x <= n && !vis[next.x])
    		{
    			vis[next.x] = true;
    			next.cnt = pre.cnt + 1;
    			Q.push(next);
    		}
    
    		next.x = pre.x - floors[pre.x].x;
    		if(next.x >= 1 && next.x <= n && !vis[next.x])
    		{
    			vis[next.x] = true;
    			next.cnt = pre.cnt + 1;
    			Q.push(next);
    		}
    	}
    	return -1;
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int a, b;
    	while (scanf("%d", &n) != EOF)
    	{
    		if(n == 0) break;
    		memset(vis, false, sizeof(vis));
    		scanf("%d %d", &a, &b);
    		for(int i = 1; i <= n; i++)
    		{
    			scanf("%d", &floors[i].x);
    			floors[i].cnt = 0;
    		}
    		vis[a] = true;
    		printf("%d\n", bfs(a, b));
    	}
    	return 0;
    }


  • 相关阅读:
    APOLLO DEV环境列表无法显示解决,重启对应的Apollo服务
    lambda Group分组示例
    Lambda 测试示例
    spring jpa restful请求示例
    部署jar项目服务命令
    java中判断一个String字符串或字符数组中包含某个字段
    LocalDateTime日期相互转换字符串
    linux nginx命令 查找目录和重启
    lambda Predicate示例
    SQL索引优化,菜单列表优化
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835103.html
Copyright © 2020-2023  润新知