• HDU 1081 To The Max (DP) 扩展最大子列和,求最大子矩阵和


    To The Max

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3768    Accepted Submission(s): 1798


    Problem Description
    Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

    As an example, the maximal sub-rectangle of the array:

    0 -2 -7 0
    9 2 -6 2
    -4 1 -4 1
    -1 8 0 -2

    is in the lower left corner:

    9 2
    -4 1
    -1 8

    and has a sum of 15.
     
    Input
    The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
     
    Output
    Output the sum of the maximal sub-rectangle.
     
    Sample Input
    4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
     
    Sample Output
    15
     
    Source
     
     
     
    #include<stdio.h>
    #include<string.h>
    #define MAXN 110
    int map[110][110];
    /*//数组a,长度为n,的最大连续子段和*/
    int MaxSubArray(int *a,int n)
    {
    int Max=-65535;
    int i,tmp=0;
    for(i=0;i<n;i++)
    {
    if(tmp>0)tmp+=a[i];
    else tmp=a[i];
    if(tmp>Max) Max=tmp;
    }
    return Max;
    }
    /*//求 n 行,m 列的矩阵的最大子矩阵和 */
    int MaxSubMatrix(int n,int m)
    {
    int Max=-65535;
    int i,j,k;
    int sum;
    int b[MAXN];
    for(i=0;i<n;i++)
    {
    memset(b,0,sizeof(b));
    for(j=i;j<n;j++)
    {
    for(k=0;k<m;k++) b[k]+=map[j][k];
    sum=MaxSubArray(b,m);
    if(sum>Max)Max=sum;
    }
    }
    return Max;
    }
    int main()
    {
    int n;
    int i,j;
    while(scanf("%d",&n)!=EOF)
    {
    for(i=0;i<n;i++)
    for(j=0;j<n;j++)
    scanf("%d",&map[i][j]);
    printf("%d\n",MaxSubMatrix(n,n));
    }
    return 0;
    }
  • 相关阅读:
    GitHub入门教程
    转:使用ActiveX插件时object显示问题,div被object标签遮挡的解决方案
    windows集成资料
    转:获取windows凭证管理器明文密码
    转: OVER() 系列函数介绍
    SQL Prompt 快捷键
    转:敏捷开发之Scrum扫盲篇
    转:修改IIS虚拟目录名称bat脚本
    转:EditPuls 5.0 注册码
    转:RowVersion 用法
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2261601.html
Copyright © 2020-2023  润新知