• H


    Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

    You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

    Input

    The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

    Output

    There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

    Sample Input

    10
    5
    1 2 even
    3 4 odd
    5 6 even
    1 6 even
    7 10 odd

    Sample Output

    3
    #include<iostream>
    #include<map>
    #include<string>
    #include<algorithm>
    #include<cstdio>
    #include<queue>
    #include<cstring>
    #include<cmath>
    #include<vector>
    #include<set>
    #include<queue>
    #include<iomanip>
    #include<iostream>
    using namespace std;
    #define MAXN 10004
    #define INF 0x3f3f3f3f
    typedef long long LL;
    /*
    数据量太大,数组开不下,在这里用map+并查集
    */
    int pre[MAXN],rank[MAXN],n,m,tol;
    map<int,int> Mp;
    int insert(int x)
    {
        if(Mp.find(x)==Mp.end())
            Mp[x] = tol++;
        return Mp[x];
    }
    int find(int x)
    {
        if(pre[x]==-1)
            return x;
        int fx = pre[x];
        pre[x] = find(pre[x]);
        rank[x] = (rank[x]+rank[fx])%2;
        return pre[x];
    }
    int main()
    {
        while(scanf("%d%d",&n,&m)==2)
        {
            memset(pre,-1,sizeof(pre));
            memset(rank,0,sizeof(rank));
            tol = 0;
            Mp.clear();
            int x,y,d,u,v,i;
            char op[10];
            bool  f = false;
            for(i=1;i<=m;i++)
            {
                cin>>x>>y>>op;
                if(f) continue;
                d = (op[0]=='e')?0:1;
                u = insert(x-1);
                v = insert(y);
                int f1 = find(u),f2 = find(v);
                if(f1==f2)
                {
                    if((rank[u]+d)%2!=rank[v])
                    {
                        f = true;
                        cout<<i-1<<endl;
                        continue;
                    }
                }
                else
                {
                    pre[f2] = f1;
                    rank[f2] = (rank[u]-rank[v]+d+2)%2;
                }
            }
            if(!f)
                cout<<m<<endl;
        }
        return 0;
    }
  • 相关阅读:
    iOS 获取手机当前所连接的网络的IP地址
    np.delete详解
    np.concatenate函数
    说说如何在 Python 中使用日志
    Python os.getcwd() 方法
    python的构造函数
    python引入自己写的Py文件
    VS CODE编译Python输出中文乱码
    VScode中pytorch出现Module 'torch' has no 'xx' member错误
    matlab处理hd5高维数据
  • 原文地址:https://www.cnblogs.com/joeylee97/p/6601568.html
Copyright © 2020-2023  润新知