• HDU1014:Uniform Generator


    Problem Description
    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where '%' is the modulus operator.  

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.  

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.  

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.  

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.  
     
    Input
    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
     
    Output
    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
     
    Sample Input
    3 5 15 20 63923 99999
     
    Sample Output
    3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
     
    #include <stdio.h>
    #include <string.h>
    
    int hash[1000000];
    int seed[1000000];
    
    int main()
    {
        int step,mod,i;
    
        while(~scanf("%d%d",&step,&mod))
        {
            memset(hash,0,sizeof(hash));
            seed[0] = 0;
            hash[0] = 1;
            int flag = 0;
            for(i = 1; i<1000000; i++)
            {
                seed[i] = (seed[i-1]+step)%mod;
                hash[seed[i]] = 1;
                /* else
                 {
                     flag = 0;
                     break;
                 }
                 */
            }
            for(i = 0; i<mod; i++)
            {
                if(!hash[i])
                    break;
            }
            if(i>=mod)
                flag = 1;
            if(flag)
                printf("%10d%10d    Good Choice\n\n",step,mod);
            else
                printf("%10d%10d    Bad Choice\n\n",step,mod);
        }
    
        return 0;
    }
    


  • 相关阅读:
    常用JVM配置参数
    JVM运行机制
    go 奇技淫巧
    如何实现LRU(最近最少使用)缓存淘汰算法?
    数组下标为什么是0而不是1?
    ServiceMesh 演化进程
    CAP定理详解
    vscode 调试配置信息
    Ubuntu 断网问题解决
    ubuntu 关闭指定占用端口
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/2999685.html
Copyright © 2020-2023  润新知