• A problem is easy


    A problem is easy

    描述

    When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

    One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
    Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
    Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

     
    输入
    The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11).
    输出
    For each case, output the number of ways in one line
    样例输入
    2
    1
    3
    样例输出
    0
    1

     
    #include <iostream>
    #include <cmath>
    using namespace std;
    int main()
    {
        int n;
        int a,b;
        cin>>n;
        while(n--)
        {
            cin>>a;
            b=0;
            for(int i=2;i*i<=(a+1);i++)
            {
                int j = (a+1)/i;
                if(i*j==a+1 && i<=j)
            
                    b++;
            }
            cout<<b<<endl;
        }
    return 0;
    }        
  • 相关阅读:
    C++中派生类与基类的同名成员调用机制
    一元运算符重载
    二元运算符重载
    const修饰符在不同位置带来的效应
    C++中指针与引用的区别
    基本的查找算法
    排序算法
    指针是怎么回事
    面试总结(1)
    价值观作业
  • 原文地址:https://www.cnblogs.com/imwtr/p/4069528.html
Copyright © 2020-2023  润新知