• hdu 2795 Billboard 线段树 单点更新


    Billboard

    Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6525    Accepted Submission(s): 2957


    Problem Description
    At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

    On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

    Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

    When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

    If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

    Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
     

    Input
    There are multiple cases (no more than 40 cases).

    The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

    Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
     

    Output
    For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
     

    Sample Input
    3 5 5 2 4 3 3 3
     

    Sample Output
    1 2 1 3 -1
     

    -------------

    注意h<10^9 所以当h>n时要让h=n,防止线段树爆掉。

    -------------

    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #include<algorithm>
    #define N 222222
    
    using namespace std;
    
    int num[N];
    
    struct Tree
    {
        int l;
        int r;
        int max;
    }tree[N*4];
    
    void push_up(int root)
    {
        tree[root].max=max(tree[root<<1].max,tree[root<<1|1].max);
    }
    
    void build(int root,int l,int r)
    {
        tree[root].l=l;
        tree[root].r=r;
        if(tree[root].l==tree[root].r)
        {
            tree[root].max=num[l];
            return;
        }
        int mid=(l+r)/2;
        build(root<<1,l,mid);
        build(root<<1|1,mid+1,r);
        push_up(root);
    }
    
    int updata(int root,int val)
    {
        int ret=0;
        if (tree[root].l==tree[root].r)
        {
            tree[root].max-=val;
            return tree[root].l;
        }
        if (tree[root<<1].max>=val)
        {
            ret=updata(root<<1,val);
        }
        else
        {
            ret=updata(root<<1|1,val);
        }
        push_up(root);
        return ret;
    }
    
    int main()
    {
        int h,w,n,t;
        while (~scanf("%d%d%d",&h,&w,&n))
        {
            if (h>n) h=n;
            for (int i=1;i<=h;i++) num[i]=w;
            build(1,1,h);
            for (int i=1;i<=n;i++)
            {
                scanf("%d",&t);
                if (tree[1].max<t) printf("-1\n");
                else printf("%d\n",updata(1,t));
            }
        }
        return 0;
    }
    






  • 相关阅读:
    非确定的自动机NFA确定化为DFA--作业8
    正规式到正规文法与自动机--作业7
    正规文法与正规式--作业六
    词法分析程序的设计与实现--作业五
    文法和语文总结与梳理--作业4
    语法树,短语,直接短语,句柄--作业
    文法和语言--作业
    作业-编译原理概述
    js实现线性结构转树形结构(生成无限层级菜单)
    基于PriorityQueue(优先队列)解决TOP-K问题
  • 原文地址:https://www.cnblogs.com/cyendra/p/3226376.html
Copyright © 2020-2023  润新知