• HDOJ 1339 A Simple Task(简单数学题,暴力)


    Problem Description
    Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

    Example

    For n = 24, o = 3 and p = 3.

    Task

    Write a program which for each data set:

    reads a positive integer n,

    computes the odd integer o and the nonnegative integer p such that n = o2^p,

    writes the result.

    Input
    The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

    Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

    Output
    The output should consists of exactly d lines, one line for each data set.

    Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

    Sample Input
    1
    24

    Sample Output
    3 3

    思路:
    就是一个公式: n = o*2^p.
    n是输入的,o和p是我们须要求的。
    须要注意的是o必须是奇数!


    0<=p的。

    import java.util.Scanner;
    
    public class Main{
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
            while(t-->0){
                int n = sc.nextInt();
                int a=0;
                int o=0;
                for(int p=0;p<n;p++){
                    a=(int)Math.pow(2, p);
                    if(a>n){
                        break;
                    }
                    if(n%a==0){
                        o=n/a;
                        if(o%2==0){
                            continue;
                        }
                        a=p;
                        break;
                    }
                }
                System.out.println(o+" "+a);
            }
    
        }
    
    }
    
  • 相关阅读:
    MVC是什么?
    Slice Header中的field_pic_flag的含义?
    Slice header 中的frame_num的含义?
    上下文管理器 contextlib
    mixin模式特点
    Flask中路由原理
    使用Docker搭建Django,Nginx,R,Python部署环境
    使用Docker+Jenkins自动构建部署
    Jenkins 关闭和重启
    使用pipenv管理python项目
  • 原文地址:https://www.cnblogs.com/brucemengbm/p/7340028.html
Copyright © 2020-2023  润新知