• pat 1006. Sign In and Sign Out (25)


    1006. Sign In and Sign Out (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
    

    where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:
    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    
    Sample Output:
    SC3021234 CS301133
    解:这一题主要是考虑好值的存储,我定义结构体,期间定义了很多乱七八糟的,最终归位string id;string time1,time2;int t1,t2;,其实直接把string time1,time2去掉也是可以的。好的是这一题时间格式很固定,我们可以算出每个人的进出时间,再进行比较,得到进时间的最小值,出时间的最大值。我们存储下标,最后输出下标对应的id值即可。

    代码:

    #include<iostream>
    #include<cstdlib>
    #include<cstdio>
    using namespace std;
    struct person
    {
        string id;
        string time1,time2;
        int t1,t2;
    };
    int main()
    {
        int num;
        while(scanf("%d",&num)==1)
        {
            int  in,out;
            getchar();
            person *p=new person[num+1];
            for(int i=0;i<num;i++)
            {
                cin>>p[i].id>>p[i].time1>>p[i].time2;
                p[i].t1=((p[i].time1[0]-48)*10+p[i].time1[1]-48)*3600+((p[i].time1[3]-48)*10+p[i].time1[4]-48)*60+(p[i].time1[6]-48)*10+(p[i].time1[7]-48);
                p[i].t2=((p[i].time2[0]-48)*10+(p[i].time2[1]-48))*3600+((p[i].time2[3]-48)*10+(p[i].time2[4]-48))*60+(p[i].time2[6]-48)*10+(p[i].time2[7]-48);
            }
            int mint=10000000,maxt=0;
            for(int j=0;j<num;j++)
            {
                if(p[j].t1<mint)
                {
                    mint=p[j].t1;
                    in=j;
                }
                if(p[j].t2>maxt)
                {
                    maxt=p[j].t2;
                    out=j;
                }
            }
            cout<<p[in].id<<" "<<p[out].id<<endl;
        }
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    团队作业六
    团队作业五
    团队作业(四)
    团队作业(三)
    团队作业二
    宇宙圣斗士队介绍
    团队作业之七
    团队作业之六
    团队作业五
    奥特曼小分队之四(Work Breakdown Structure)
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965307.html
Copyright © 2020-2023  润新知