• [解题报告]113 Power of Cryptography


     Power of Cryptography 

    Background

    Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.

    This problem involves the efficient computation of integer roots of numbers.

    The Problem

    Given an integer tex2html_wrap_inline32 and an integer tex2html_wrap_inline34 you are to write a program that determines tex2html_wrap_inline36 , the positivetex2html_wrap_inline38 root of p. In this problem, given such integers n and pp will always be of the form tex2html_wrap_inline48 for an integerk (this integer is what your program must find).

    The Input

    The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs tex2html_wrap_inline56 , tex2html_wrap_inline58 and there exists an integer ktex2html_wrap_inline62 such that tex2html_wrap_inline64 .

    The Output

    For each integer pair n and p the value tex2html_wrap_inline36 should be printed, i.e., the number k such that tex2html_wrap_inline64 .

    Sample Input

    2
    16
    3
    27
    7
    4357186184021382204544

    Sample Output

    4
    3
    1234



    水的一塌糊涂,不解释了
    #include<stdio.h>
    #include<math.h> int main() { double n,p; while(scanf("%lf%lf",&n,&p)!=EOF) printf("%.0lf\n",pow(p,1.0/n)); return 0; }

     HDU AC

    #include <stdio.h>
    #include <math.h>
    int main()
    {
        double n;
        double p;
        while(scanf("%lf%lf",&n,&p)!=EOF)
        {
            int begin=1;
            int end=1000000000;
            int mid;
            while (begin <= end)
            {
                mid=(begin+end)/2;
                double temp=pow(mid,n);
                if (temp==p) 
                    {
                    printf("%d\n",mid);
                    break;
                } 
                else if(temp>p) 
                    {
                    end=mid-1;
                } 
                else
                {
                    begin = mid + 1;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    MySQL 数据恢复
    由 go orm 引发的探索
    beego 优雅重启
    2020年8月20日
    Linux 递归获取目录下所有满足条件的文件
    NET Core Kestrel部署HTTPS 一个服务器绑一个证书 一个服务器绑多个证书
    Flutter环境配置-windows
    Vue获取钉钉免登陆授权码(vue中的回调函数实践)
    【C#上位机必看】你们要的Iot物联网项目来了
    Windows Server系统部署MySQL数据库
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2919100.html
Copyright © 2020-2023  润新知