• PAT (Advanced Level) Practice 1099 Build A Binary Search Tree (30分) (二叉搜索树)


    1.题目

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

    figBST.jpg

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:

    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42
    

    Sample Output:

    58 25 82 11 38 67 45 73 42

    2.题目分析

    首先按照所给的左右节点静态建树,把data数据空下,我们知道二叉搜索树的中序遍历是从小到大的,所有用数组记录节点data再sort排序,然后在数中进行中序遍历为数中的data赋值,最后再进行层序遍历

     3.代码

    #include<iostream>
    #include<queue>
    #include<algorithm>
    using namespace std;
    struct node
    {
    	int data;
    	int left;
    	int right;
    }list[110],temp;
    int n;
    int nodelist[110];
    void inorder(int head,int &amount)
    {
    	if(list[head].left!=-1)inorder(list[head].left,amount);
    	list[head].data = nodelist[amount++];
    	if (list[head].right != -1)inorder(list[head].right, amount);
    }
    bool space = false;
    void level(int head)
    {
    	queue<node>out;
    	out.push(list[head]);
    	while (!out.empty())
    	{
    		temp = out.front(); out.pop();
    		printf("%s%d", space == false ? "" : " ", temp.data); space = true;
    		if (temp.left != -1)out.push(list[temp.left]);
    		if (temp.right!= -1)out.push(list[temp.right]);
    	}
    }
    int main()
    {
    	scanf("%d", &n);
    	for (int i = 0; i < n; i++)
    		scanf("%d %d", &list[i].left, &list[i].right);
    	for (int i = 0; i < n; i++)
    		scanf("%d", &nodelist[i]);
    	sort(nodelist, nodelist + n);
    	int amount = 0;
    	inorder(0, amount);
    	level(0);
    }
  • 相关阅读:
    到具体某一天的倒计时
    angular2 2种方式----获取子组件的类属性和类方法
    页面刷新
    angular父子组件传值
    div垂直居中,文字垂直居中!!!
    Python 基础数据类型 II (列表)
    Python 基础数据类型 I (str等)
    学习笔记411
    20190407 Word合并单元格
    VBA正则笔记 理解肯定环视
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788840.html
Copyright © 2020-2023  润新知