• SGU[184] Patties


    Description

    描述

    Petya is well-known with his famous cabbage patties. Petya's birthday will come very soon, and he wants to invite as many guests as possible. But the boy wants everybody to try his specialty of the house. That's why he needs to know the number of the patties he can cook using the stocked ingredients. Petya has P grams of flour, M milliliters of milk and C grams of cabbage. He has plenty of other ingredients. Petya knows that he needs K grams of flour, R milliliters of milk and V grams of cabbage to cook one patty. Please, help Petya calculate the maximum number of patties he can cook.

    Peyta因为他的白菜馅饼非常知名。Peyta的生日快要到了,他想邀请尽可能多的宾客参加他的生日晚会。但是男孩们希望每个人都希望展示自己居家的特长。这就是为什么他希望知道他能够使用备用原料制作多少个馅饼。Petya有P克面粉,M毫升牛奶,C克白菜。他还有很多其他的原料。Peyta知道他需要K克面粉,R毫升牛奶,V克白菜来制作一个馅饼。请你帮Peyta计算一下他最多能够制作多少个馅饼。

     

    Input

    输入

    The input file contains integer numbers P, M, C, K, R and V, separated by spaces and/or line breaks (1 <= P, M, C, K, R, V <= 10000).

    输入文件包含P,M,C,K,R,V,以空格或换行分隔(1 <= P, M, C, K, R, V <= 10000)。


    Output

    输出

    Output the maximum number of patties Petya can cook.

    输出Petya最多能够制作的馅饼数。


    Sample Input

    样例输入

    3000 1000 500
    30 15 60


    Sample Output

    样例输出

    8

     

    Analysis

    分析

    简单的数学分析就知道,所求答案为P / K, M / R, C / V的最小值。

     

    Solution

    解决方案

    #include <iostream>
    
    using namespace std;
    
    int min(int x, int y, int z);
    
    int main()
    {
    	int P, M, C, K, R, V;
    	cin >> P >> M >> C;
    	cin >> K >> R >> V;
    	cout << min(P / K, M / R, C / V) << endl;
    	return 0;
    }
    
    int min(int x, int y, int z)
    {
    	return min(x, min(y, z));
    }
    

     

    这道题目涉及到的一个数学思想是——短板理论。

    也就是决定能够制作多少个馅饼的数目是由各个原料能够制作的馅饼数的最小值来决定的。

    短板理论在我们的日常生活中也很常见。我们也要经常发现自己的短板所在,并对其进行提升,进一步的完善自我,提升自我。

  • 相关阅读:
    5,pandas高级数据处理
    4,根据美国各州人口,土地面积进行数据分析
    3,Python常用库之三:Matplotlib
    2,Python常用库之二:Pandas
    1,Python常用库之一:Numpy
    18,增量式爬虫
    17,基于scrapy-redis两种形式的分布式爬虫
    http超文本传输协议,get与post区别
    优化css,增加性能
    bootstrap常用知识点总结
  • 原文地址:https://www.cnblogs.com/Ivy-End/p/4262917.html
Copyright © 2020-2023  润新知