• hdu 1002 A+B problem II


    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002

    题目分析:高精度问题,大整数相加。 由此题可见java相较于C/C++的优势,即丰富多彩的类以及强大的字符串/IO处理机制。调用BigeInteger类,减少了太多麻烦~~

    /*A + B Problem II
    
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 237263    Accepted Submission(s): 45690
    
    
    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    
    Sample Input
    2
    1 2
    112233445566778899 998877665544332211
     
    
    Sample Output
    Case 1:
    1 + 2 = 3
    
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110
     
    
    Author
    Ignatius.L
     
    */
    // BigInteger
    import java.util.*;
    import java.math.*;
    public class Main {
    
        public static void main(String[] args) {
            // TODO Auto-generated method stub
            Scanner in = new Scanner(System.in);
            BigInteger a, b;
            int n = in.nextInt();
            for(int i = 1; i <= n; i++){
                a = in.nextBigInteger();
                b = in.nextBigInteger();
                System.out.println("Case "+i+":");
                System.out.println(a+" + "+b+" = "+a.add(b));
                if(i != n) System.out.println();
            }
        }
    
    }
  • 相关阅读:
    环境部署:Linux下查看JDK安装路径
    环境部署(一):Linux下安装JDK
    linux常见命令
    设计用例
    测试用例的优先级
    快速幂和快速乘
    docker-compose安装
    jmeter通过命令生成自动测试报告
    jmeter环境变量配置
    java将毫秒转化为当前时间
  • 原文地址:https://www.cnblogs.com/ACFLOOD/p/4279193.html
Copyright © 2020-2023  润新知