• PAT1118:Birds in Forest


    1118. Birds in Forest (25)

    时间限制
    150 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
    K B1 B2 ... BK
    where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

    After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

    Output Specification:

    For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.

    Sample Input:
    4
    3 10 1 2
    2 3 4
    4 1 5 7 8
    3 9 6 4
    2
    10 5
    3 7
    
    Sample Output:
    2 10
    Yes
    No

    思路

    并查集的应用,
    1.输入的时候将每只鸟合并到相关的集合中,并确定共同的源点鸟来代表这个集合,用一个bool数字birds标识一只鸟的存在。
    2.集合数就是树的棵数,birds中为true值的变量总数就是鸟的数量
    3.判断两只鸟是否在一棵树上其实就是判断它们的源点鸟是否一样就行。

    代码
    #include<iostream>
    #include<vector>
    using namespace std;
    const int maxnum = 10002;
    //并查集
    vector<int> sources(maxnum);  //某个点的源点
    vector<int> cntnum(maxnum,0);   //该源点点下的鸟个数
    vector<bool> birds(maxnum,false);   //标识鸟的存在
    
    
    void Init() //初始化
    {
        for(int i = 1;i < maxnum;i++)
            sources[i] = i;
    }
    
    int findsource(int x)
    {
        int y = x; //索引
        while( x != sources[x]) //找最初源点
        {
            x = sources[x];
        }
    
        while( y != sources[y])
        {
            int tmp = y;
            y = sources[y]; //继续找
            sources[tmp] = x; //将所有相关点的源点统一
        }
    
        return x;
    }
    
    
    void Union(int x,int y) //合并两个相关集
    {
        int xsource = findsource(x);
        int ysource = findsource(y);
        if(xsource != ysource)
        {
            sources[xsource] = ysource; //合并
        }
    }
    
    
    int main()
    {
        int N;
        Init();
        while(cin >> N)
        {
            //输入
            for(int i = 0;i < N;i++)
            {
                int K,first;
                cin >> K >> first;
                birds[first] = true;
                for(int j = 0 ;j < K - 1;j++)
                {
                    int tmp;
                    cin >> tmp;
                    birds[tmp] = true;
                    Union(first,tmp);
                }
            }
    
            //处理
            int treenum = 0,birdsum = 0;
            for(int i = 1;i < maxnum;i++)
            {
               if(birds[i])
                 ++cntnum[sources[i]];
            }
    
            for(int i = 1;i < maxnum;i++)
            {
                if(cntnum[i] != 0)
                {
                    if(sources[i] == i)
                        treenum++;
                    birdsum += cntnum[i];
                }
            }
            //输出多少棵树多少只鸟
            cout << treenum << " " << birdsum << endl;
            //查询
            int Q;
            cin >> Q;
            for(int i = 0;i < Q;i++)
            {
                int a,b;
                cin >> a >> b;
                if(findsource(a) == findsource(b))
                    cout << "Yes" << endl;
                else
                    cout << "No" << endl;
            }
        }
    }
    

      

  • 相关阅读:
    C#中Split用法
    ASP.NET Get和Post两种提交的区别:
    BAT常用命令
    SQL语句:在两个数据库间复制表结构和数据数据库
    C#中Array与ArrayList用法及转换
    找出输入区间内的回文质数
    (转)加藤嘉一:中国大学生,你没资格抱怨政府
    最长公共子序列(LCS)
    shell(希尔)排序
    关于Ubuntu中google chrome浏览器字体的设置
  • 原文地址:https://www.cnblogs.com/0kk470/p/7884113.html
Copyright © 2020-2023  润新知