• hdu 2141 Can you find it?


    Problem Description
    Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
     
    Input
    There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
     
    Output
    For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
     
    Sample Input
    3 3 3
    1 2 3
    1 2 3
    1 2 3
    3
    1
    4
    10
     
    Sample Output
    Case 1:
    NO
    YES
    NO
    View Code
    #include"stdio.h"   
    #include"string.h"   
    #include"stdlib.h"   
      
    int tot[3];  
    int x[511];  
    int y[511];  
    int z[511];  
    int d[251111],k;  
      
    int cmp(const void *a,const void *b)  
    {  
        return *(int *)a-*(int *)b;  
    }  
    int main()  
    {  
        int Case=1,n;  
        int i,l;  
        int aim,temp,flag;  
        int low,up,mid;  
      
        while(scanf("%d%d%d",&tot[0],&tot[1],&tot[2])!=-1)  
        {  
            qsort(tot,3,sizeof(tot[0]),cmp);  
            for(i=0;i<tot[0];i++)    scanf("%d",&x[i]);  
            for(i=0;i<tot[1];i++)    scanf("%d",&y[i]);  
            for(i=0;i<tot[2];i++)    scanf("%d",&z[i]);  
            qsort(x,tot[0],sizeof(x[0]),cmp);  
      
            k=0;  
            for(i=0;i<tot[1];i++)  
            for(l=0;l<tot[2];l++)  
                d[k++]=y[i]+z[l];  
            qsort(d,k,sizeof(d[0]),cmp);  
      
            scanf("%d",&n);  
            printf("Case %d:\n",Case++);  
            while(n--)  
            {  
                scanf("%d",&aim);  
                flag=0;  
                for(i=0;i<tot[0];i++)  
                {  
                    temp=aim-x[i];  
      
                    low=0;up=k-1;mid=(low+up)/2;  
                    while(up-low>1)  
                    {  
                        if(d[mid]>temp)      up=mid;  
                        else if(d[mid]<temp)low=mid;  
                        else                {flag=1;break;}  
                        mid=(low+up)/2;  
                    }  
                    if(d[low]==temp || d[up]==temp) flag=1;  
      
                    if(flag)    break;  
                }  
                if(flag)    printf("YES\n");  
                else        printf("NO\n");  
            }  
        }  
        return 0;  
    }  
  • 相关阅读:
    [BZOJ 1295][SCOI2009]最长距离(SPFA+暴力)
    [BZOJ 3143][HNOI2013]游走(数学期望)
    [BZOJ 1797][AHOI2009]最小割(最小割关键边的判断)
    [BZOJ1876][SDOI2009]superGCD(高精度)
    [BZOJ1801][AHOI2009]中国象棋(递推)
    [bzoj2245][SDOI2011]工作安排(费用流)
    [bzoj 1064][NOI2008]假面舞会(dfs判断环)
    [BZOJ 1486][HNOI2009]最小圈(二分答案+dfs写的spfa判负环)
    2.3、操纵json、parquet、jdbc数据库
    输入框中的添加回车事件
  • 原文地址:https://www.cnblogs.com/zlyblog/p/3034310.html
Copyright © 2020-2023  润新知