• PAT 甲级 1068 Find More Coins


    https://pintia.cn/problem-sets/994805342720868352/problems/994805402305150976

    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 1coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤, the total number of coins) and M (≤, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the face values V1​​V2​​Vk​​ such that V1​​+V2​​++Vk​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

    Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

    Sample Input 1:

    8 9
    5 9 8 7 2 3 4 1
    

    Sample Output 1:

    1 3 5
    

    Sample Input 2:

    4 8
    7 2 4 3
    

    Sample Output 2:

    No Solution

    代码:

    #include <bits/stdc++.h>
    using namespace std;
    
    const int maxn = 1e4 + 10;
    int N, M;
    int num[maxn], dp[maxn];
    bool vis[maxn][110];
    
    int cmp(int a, int b) {
        return a > b;
    }
    
    int main() {
        scanf("%d%d", &N, &M);
        for(int i = 1; i <= N; i ++)
            scanf("%d", &num[i]);
        sort(num + 1, num + 1 + N, cmp);
    
        for(int i = 1; i <= N; i ++) {
            for(int j = M; j >= num[i]; j --) {
                if(dp[j] <= dp[j - num[i]] + num[i]) {
                    vis[i][j] = true;
                    dp[j] = dp[j - num[i]] + num[i];
                }
            }
        }
        if(dp[M] != M) printf("No Solution");
        else {
            vector<int> ans;
            int sum = M, st = N;
            while(sum > 0) {
                if(vis[st][sum]) {
                    ans.push_back(num[st]);
                    sum -= num[st];
                }
                st --;
            }
    
            for(int i = 0; i < ans.size(); i ++) {
                if(i != 0) printf(" ");
                printf("%d", ans[i]);
            }
        }
        return 0;
    }
    

      这个居然是个 01 背包 没看出来 哭唧唧

  • 相关阅读:
    【DP】解析 SOSdp(子集和 dp)
    【图论】AcWing 342. 道路与航线 题目解答 (拓扑序+dijkstra)
    【DP】斜率优化初步
    Educational Codeforces Round 95 (Rated for Div. 2) 题解(待更)
    2020-2021 ACM-ICPC, Asia Seoul Regional Contest 部分题目解答
    Codeforces Round #704 (Div. 2) 题解(待更)
    Samara Farewell Contest 2020 (XXI Open Cup, GP of Samara) 部分题目解答
    AtCoder Regular Contest 113 题解(待补)
    docker中php-fpm无法更改时区问题
    pod时区更改
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/10361640.html
Copyright © 2020-2023  润新知