• hdu3746 Cyclic Nacklace(kmp)


    题目传送门

    Cyclic Nacklace

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 15508    Accepted Submission(s): 6461


    Problem Description
    CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

    As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

    Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
    CC is satisfied with his ideas and ask you for help.
     
    Input
    The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
    Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
     
    Output
    For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
     
    Sample Input
    3 aaa abca abcde
     
    Sample Output
    0 2 5
     
    Author
    possessor WC
     
     
     
     
     
    Source
     
    Recommend
    lcy   |   We have carefully selected several similar problems for you:  3336 1358 1686 1711 2222 
    题意:求再加几个,字符串才能构成循环
    题解:这题可以分成三种情况:
    1、字符串本身已经循环,此时输出0;
    2、字符串不循环,此时输出len;
    3、字符串还差几个就循环了,这是我们利用kmp的next数组,即先判断它的
    循环节是多少,然后循环节长度-len%循环节即可。
    代码:
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    #include<string>
    #include<stdio.h>
    #include<queue>
    using namespace std;
    typedef long long ll;
    typedef unsigned long long ull;
    typedef long long ll;
    typedef pair<int,int> PII;
    #define mod 1000000007
    #define pb push_back
    #define mp make_pair
    #define all(x) (x).begin(),(x).end()
    #define fi first
    #define se second
    //head
    #define MAX 100005
    string s;
    int Next[MAX];
    int len;
    void get_next()
    {
        int i=0,j=-1;
        Next[i]=j;
        for(i=1;i<len;i++)
        {
            while(j>-1&&s[j+1]!=s[i])
                j=Next[j];
            if(s[j+1]==s[i]) j++;
            Next[i]=j;
        }
    }
    int work()
    {
        int tmp=len-1-Next[len-1];
        if(Next[len-1]==-1)
            return len;
        else if(len%tmp==0)
            return 0;
        else return tmp-len%tmp;
    }
    int main()
    {
        int T;
        cin>>T;
        while(T--)
        {
            cin>>s;
            memset(Next,0,sizeof(Next));
            len=s.size();
            get_next();
            /*for(int i=0;i<len;i++)
                cout<<Next[i]<<" ";*/
            cout<<work()<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    国密在车联网安全认证场景中的应用
    EMQX + 阿里云 Tablestore 多场景一站式 IoT 数据解决方案
    国内首个开源物联网边缘工业协议网关软件,Neuron v2.0 产品解读
    使用 NodeRED 处理 MQTT 数据
    【友晶科技Terasic】功能仿真之前 到底要不要先进行综合?
    【友晶科技Terasic】关于SDRAM 的若干问题解答
    20192417 实验六 Metasploit攻击渗透实践
    20192417 实验七 网络欺诈与防范
    纯文本流程图工具 Graph::Easy
    网络拓扑 fattree vs. Jellyfish
  • 原文地址:https://www.cnblogs.com/zhgyki/p/9649463.html
Copyright © 2020-2023  润新知