• 1053 Path of Equal Weight (30 分)树的遍历,vector数组排序,优先级队列


    1053 Path of Equal Weight (30 分)

    Given a non-empty tree with root RRR, and with weight WiW_iWi​​ assigned to each tree node TiT_iTi​​. The weight of a path from RRR to LLL is defined to be the sum of the weights of all the nodes along the path from RRR to any leaf node LLL.

    Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 0<N≤1000 < N le 1000<N100, the number of nodes in a tree, MMM (<N< N<N), the number of non-leaf nodes, and 0<S<2300 < S < 2^{30}0<S<230​​, the given weight number. The next line contains NNN positive numbers where WiW_iWi​​ (<1000<1000<1000) corresponds to the tree node TiT_iTi​​. Then MMM lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

    Output Specification:

    For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

    Note: sequence {A1,A2,⋯,An}{A_1, A_2, cdots , A_n}{A1​​,A2​​,,An​​} is said to be greater than sequence {B1,B2,⋯,Bm}{B_1, B_2, cdots , B_m}{B1​​,B2​​,,Bm​​} if there exists 1≤k<min{n,m}1 le k < min{n, m}1k<min{n,m} such that Ai=BiA_i = B_iAi​​=Bi​​ for i=1,⋯,ki=1, cdots , ki=1,,k, and Ak+1>Bk+1A_{k+1} > B_{k+1}Ak+1​​>Bk+1​​.

    Sample Input:

    20 9 24
    10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
    00 4 01 02 03 04
    02 1 05
    04 2 06 07
    03 3 11 12 13
    06 1 09
    07 2 08 10
    16 1 15
    13 3 14 16 17
    17 2 18 19
    

    Sample Output:

    10 5 2 7
    10 4 10
    10 3 3 6 2
    10 3 3 6 2
    思路:
      我的整体思路是先求权重数组再排序,题目要求多个权重数组的输出顺序是非递减,所以我使用了优先级
    队列来存放在dfs遍历中求得的权重数组。这样最后直接输出即可。ac以后,我看了一下别人的代码,他们的
    做法大多是先排序再求权重数组,这样在dfs算法return之前直接输出,不必存储,比我的高效。我能够ac主
    要原因是priority_queue<vector<int>>的排序方法和题中要求的大小比较规则相一致。
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    #include<stack>
    using namespace std;
    vector<vector<int>> tree;
    int visited[101];
    int weight[101];
    vector<int> path;
    priority_queue<vector<int>> qu;
    
    void dfs(int currentSum,int s,int index)
    {
        if(currentSum>s)
            return;
        if(currentSum==s&&tree[index].empty())
        {
            qu.push(path);
            return;
        }
        for(auto num:tree[index])
        {
            //string temp=path;
            if(visited[num]==0)
            {
                visited[num]=1;
                path.push_back(weight[num]);
                dfs(currentSum+weight[num],s,num);
                path.pop_back();
                visited[num]=0;
            }
        }
    }
    
    int main()
    {
        int n,m,s;
        scanf("%d%d%d",&n,&m,&s);
    
        tree.resize(n);
        for(int i=0; i<n; i++)
            scanf("%d",&weight[i]);
        for(int i=0; i<m; i++)
        {
            int id0,k,temp;
            scanf("%d%d",&id0,&k);
            for(int j=0; j<k; j++)
            {
                cin>>temp;
                tree[id0].push_back(temp);
            }
        }
        //cout<<weight[0];
        // path+=to_string(weight[0]);
        path.push_back(weight[0]);
        //cout<<path<<endl;
        visited[0]=1;
        dfs(weight[0],s,0);
        while(!qu.empty())
        {
            vector<int> temp=qu.top();
            qu.pop();
            cout<<temp[0];
            for(int i=1; i<temp.size(); i++)
                cout<<" "<<temp[i];
            cout<<endl;
        }
    //    cout<<qu.top()<<endl;
    //    qu.pop();
    //    while(!qu.empty())
    //    {
    //        cout<<qu.top()<<endl;
    //        qu.pop();
    //    }
        return 0;
    }


  • 相关阅读:
    Delphi使用Indy、ICS组件读取网页
    用SendNotifyMessage代替PostMessage避免消息丢失
    LuaPlus的编译和引用
    如何转换和输出超大整数(64位)
    jQuery 源码:封装 Event
    jQuery 源码:操作样式
    jQuery 源码:元素位置
    模拟ES5 Array.prototype.reduce
    as 和 is 运算符以及安全的类型强制转换
    计算机编程基础
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10309712.html
Copyright © 2020-2023  润新知