• poj 1298(水题)


    The Hardest Problem Ever
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 24241   Accepted: 13227

    Description

    Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.

    You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite:


    Cipher text
    A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Plain text
    V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

    Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

    Input

    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.


    A single data set has 3 components:

    1. Start line - A single line, "START"
    2. Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar
    3. End line - A single line, "END"

    Following the final data set will be a single line, "ENDOFINPUT".

    Output

    For each data set, there will be exactly one line of output. This is the original message by Caesar.

    Sample Input

    START
    NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
    END
    START
    N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
    END
    START
    IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
    END
    ENDOFINPUT

    Sample Output

    IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
    I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
    DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
    

    Source

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<cstdlib>
    #include<cmath>
    #include<vector>
    #include<queue>
    #include<stack>
    using namespace std;
    int main(){
      //  freopen("in.txt","r",stdin);
        string s,s1,s2;
        char m[27]="VWXYZABCDEFGHIJKLMNOPQRSTU";
        int j,k;
        while(cin>>s){
            if(s=="ENDOFINPUT")
                break;
            cin.ignore(INT_MAX,'
    ');
            getline(cin,s1,'
    ');
            j=s1.size();
            for(int i=0;i<j;i++){
                if(s1[i]>='A'&&s1[i]<='Z')
                    cout<<m[s1[i]-'A'];
                else
                    cout<<s1[i];
            }
        cin>>s2;
        cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    【转载】ASP.NET Core读取appsettings.json配置文件信息
    node.js安装教程(简单易懂)
    记一次使用typescript模板初始化React项目的几个问题
    es分页查询 scroll
    Redis5设计与源码分析 (第15章 有序集合相关命令的实现)
    Redis5设计与源码分析 (第14章 集合相关命令的实现)
    Redis5设计与源码分析 (第13章 列表相关命令的实现)
    Redis5设计与源码分析 (第12章 散列表相关命令的实现)
    Redis5设计与源码分析 (第11章 字符串相关命令的实现)
    Redis5设计与源码分析 (第9章 命令处理生命周期)
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/5016202.html
Copyright © 2020-2023  润新知