• A


    Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

    Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

    Output

    * Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

    Sample Input

    4 6
    1 4
    2 6
    3 12
    2 7

    Sample Output

    23

    每个只用一次,0,1背包模板题
    #include<iostream>
    #include<cstring>
    using namespace std;
    const int maxn=1e5+1000;
    int n,m;
    int w[maxn],d[maxn];
    int dp[maxn];
    int main()
    {
        cin>>n>>m;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            cin>>w[i]>>d[i];
        }
        for(int i=0;i<n;i++)
        {
            for(int j=m;j>=w[i];j-- )
            {
                dp[j]=max(dp[j],dp[j-w[i]]+d[i]);
            }
        }
        cout<<dp[m]<<endl;
        return 0;
    } 

    选出最大,一次一次更新,

    dp[j]=max(dp[j],dp[j-w[i]]+d[i])

    用二维数组来写开1e6会炸,
        for(int i=1;i<=n;i++)
          for(int j=0;j<=m;j++)
          {
              dp[i][j]=dp[i-1][j];//不包括第i个小于j最大的值为dp[i-1][j]
    if(j>=w[i])//在范围内 dp[i][j]=max(dp[i][j],dp[i-1][j-w[i]]+d[i]); } cout<<dp[n][m]<<endl;
    
    

    转换成一维数组,用滚动数组,就可以了

      for(int i=0;i<n;i++)
        {
            for(int j=m;j>=w[i];j-- )
            {
                dp[j]=max(dp[j],dp[j-w[i]]+d[i]);
            }
        }

     



    
    
  • 相关阅读:
    01Angular开发环境配置
    不再显示广告案例(php操作cookie)
    php操作 cookie
    JPush Android 推送如何区分开发、生产环境
    10 分钟实现一个自己的服务器监控器
    iOS 轻松使用 App 数据统计
    认识本质:黑天鹅、关键时刻与张小龙的产品观
    C# 服务端推送,十步十分钟,从注册到推送成功
    聊天界面-自适应文字
    极光推送的角标问题——让人又爱又恨的小红点
  • 原文地址:https://www.cnblogs.com/ylrwj/p/11869371.html
Copyright © 2020-2023  润新知