• 1008 Elevator (20)(20 分)


    1008 Elevator (20)(20 分)

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1

    Sample Output:

    41


    在一座高楼上只有一个电梯,然后有 n 个电梯将要停止的楼层 电梯上升一层 用时 6 秒 , 下降一层用时 4 秒, 在每层停止时 停下5秒
    初始位置为 0 层, 当电梯停止在最后一个位置后不再返回 0 层
    问 电梯需要多长时间完成 n 个任务请求

    #include <iostream>
    #include <algorithm>
    
    using namespace std; 
    
    #define maxn 200
    
    int n , floors[maxn] ; 
    
    int main(){
    
        while(cin >> n ){
            for(int i=1 ; i<=n ; i++){
                cin >> floors[i] ; 
            }
            int sum = 0 ; 
            floors[0] = 0 ; // 第 0 层
    
            for(int i=1 ; i<=n ; i++){
                if(floors[i] - floors[i-1] >= 0 ){ // 上升
                    sum += (floors[i] - floors[i-1]) * 6 ; 
                }else { // 下降
                    sum += abs(floors[i] - floors[i-1]) * 4 ; 
                }
            }
            sum += n * 5 ; // 每层楼停止时 停下 5 秒
            
            cout << sum << endl ;
        }
        return 0 ; 
    }


  • 相关阅读:
    A. Vasya and Book
    B. Curiosity Has No Limits
    A. Link/Cut Tree
    C. Yuhao and a Parenthesis
    D2. Magic Powder
    B. Approximating a Constant Range
    51nod1185 威佐夫游戏 V2 (模拟乘法)
    博弈论(巴什博奕,威佐夫博弈,尼姆博弈,斐波那契博弈)
    sg函数模板
    D.Starry的神奇魔法(矩阵快速幂)
  • 原文地址:https://www.cnblogs.com/yi-ye-zhi-qiu/p/9509024.html
Copyright © 2020-2023  润新知