• 快速切题 poj2632


    Crashing Robots
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7799   Accepted: 3388

    Description

    In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
    A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

    Input

    The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
    The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
    Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
     
    Figure 1: The starting positions of the robots in the sample warehouse

    Finally there are M lines, giving the instructions in sequential order. 
    An instruction has the following format: 
    < robot #> < action> < repeat> 
    Where is one of 
    • L: turn left 90 degrees, 
    • R: turn right 90 degrees, or 
    • F: move forward one meter,

    and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

    Output

    Output one line for each test case: 
    • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
    • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
    • OK, if no crashing occurs.

    Only the first crash is to be reported.

    Sample Input

    4
    5 4
    2 2
    1 1 E
    5 4 W
    1 F 7
    2 F 7
    5 4
    2 4
    1 1 E
    5 4 W
    1 F 3
    2 F 1
    1 L 1
    1 F 3
    5 4
    2 2
    1 1 E
    5 4 W
    1 L 96
    1 F 2
    5 4
    2 3
    1 1 E
    5 4 W
    1 F 4
    1 L 1
    1 F 20

    Sample Output

    Robot 1 crashes into the wall
    Robot 1 crashes into robot 2
    OK
    Robot 1 crashes into robot 2

    简单的模拟
    应用时:15min
    实际用时:1h40min
    问题:碰撞的先后次序
    #include<cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    
    int A,B,n,m;
    int robot[101][3];
    char rbuff[10];
    int dir[255];
    const int dx[4]={0,1,0,-1};
    const int dy[4]={1,0,-1,0};
    int action[101][3];
    int tx,ty;
    int ansr;
    bool between(int aim,int gap){
        int sx=robot[gap][0];
        int sy=robot[gap][1];
        int mingx=min(sx,tx);
        int maxgx=max(sx,tx);
        int mingy=min(sy,ty);
        int maxgy=max(sy,ty);
        int ax=robot[aim][0];int ay=robot[aim][1];
        if(ax>=mingx&&ax<=maxgx&&ay>=mingy&&ay<=maxgy){
                if(ansr==0)ansr=aim;
                else {
                    if(abs(robot[ansr][0]-sx)>=abs(ax-sx)&&abs(robot[ansr][1]-sy)>=abs(ay-sy)){
                        ansr=aim;
                    }
                }
                return true;
        }
        return false;
    }
    void solve(){
        ansr=0;
        for(int i=0;i<m;i++){
            int rob=action[i][0];
            int rep=action[i][1];
            if(action[i][2]==0){
                robot[rob][2]=(robot[rob][2]+4-rep%4)%4;
            }
            else if(action[i][2]==1){
                robot[rob][2]=(robot[rob][2]+rep%4)%4;
            }
            else{
                bool fl=false;
                tx=robot[rob][0]+rep*dx[robot[rob][2]];
                ty=robot[rob][1]+rep*dy[robot[rob][2]];
                for(int j=1;j<=n;j++){
                    if(j==rob)continue;
                    if(between(j,rob)){
                        fl=true;
                    }
                }
               if(fl){
                    printf("Robot %d crashes into robot %d\n",rob,ansr);return ;
                }
                if(tx<1||tx>A||ty<1||ty>B){
                    printf("Robot %d crashes into the wall\n",rob);return ;
                }
                robot[rob][0]=tx;
                robot[rob][1]=ty;
            }
        }
        puts("OK");
    }
    
    int main(){
        #ifndef ONLINE_JUDGE
            freopen("output.txt","w",stdout);
        #endif // ONLINE_JUDGE
    dir['N']=0;dir['E']=1;dir['S']=2;dir['W']=3;
    dir['L']=0;dir['R']=1;dir['F']=2;
        int t;
        scanf("%d",&t);
        while(t--){
           scanf("%d%d%d%d",&A,&B,&n,&m);
           for(int i=1;i<=n;++i){
                scanf("%d%d%s",robot[i],robot[i]+1,rbuff);
                robot[i][2]=dir[rbuff[0]];
           }
           for(int i=0;i<m;i++){
                 scanf("%d%s%d",action[i],rbuff,action[i]+1);
                 action[i][2]=dir[rbuff[0]];
           }
           solve();
        }
        return 0;
    }
  • 相关阅读:
    anything vs everything
    cong
    invalid initialization of non-const reference of type与discards qualifiers
    gvew
    3.2存储器层次结构 -- 《深入理解计算机系统》☆☆☆☆☆
    2.2优化编译器的能力和局限性
    2.1.2优化程序性能
    2.1.1优化程序性能
    linux中获取堆栈空间大小的方法
    优美的英文诗歌Beautiful English Poetry
  • 原文地址:https://www.cnblogs.com/xuesu/p/3944092.html
Copyright © 2020-2023  润新知